Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

At domain my.test.org I have the following setup:

  • A Tomcat6 running on port 8080
  • A redirection from port 80 to 8080 at the OS level (using NAT)
  • An application deployed in Tomcat at http://my.test.org/myapp (the Pubby app, a semantic web front-end).

The issue is that the correct URL for myapp should be http://my.test.org/prefix/myapp: the app publishes linked data having http://my.test.org/prefix/myapp as prefix. For this reason it won't work at http://my.test.org/myapp. In other words, I need to re-write the URL in a transparent way, without redirections.

I tried to deploy the app in a subfolder in webapps (locally $CATALINA/webapps/prefix/myapp) with no luck.

What would be a good solution to deploy the app at http://my.test.org/prefix/myapp?

Thanks for any hint!

share|improve this question
    
Can you clarify why there's a prefix outside the application namespace? The info I'm seeing in the docs has the optional prefixes within the webapp namespace. –  Shane Madden Sep 3 '12 at 16:39
    
Yes, but those options don't seem to work. It's because the RDF dataset I want to publish has a prefix. –  Mulone Sep 3 '12 at 17:35

1 Answer 1

With tomcat you can override the prefix an app is deployed to. See the manager interface just above the upload war section, there are ~4 fields to fill in from memory.


I can't comment here yet so replying in the answer.

You may need to edit the tomcat-users.xml to add a manager role (there are comments in the file to assist) and also add a user with the manager role assigned.

Once you've done that, you should be able to access the /manager/ uri and on that screen you'll see the section I'm t Referring to.

share|improve this answer
    
Thanks! I installed the tomcat-admin package, but I can't access it. What file/interface you are talking about? –  Mulone Sep 3 '12 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.