Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am having some problem in trying to setup DNS for my domain on my server. This tutorial normally works fine for me but when i tried to lookup my domain it gives the following output

Server: 4.2.2.1 Address: 4.2.2.1#53

Non-authoritative answer: 119.100.79.64.in-addr.arpa name = server.leech4ever.com.

Authoritative answers can be found from:

The server and the address are wrong according to the tutorial

Here is tutorial

http://webcache.googleusercontent.com/search?q=cache:rR7Z4YU4GI0J:www.broexperts.com/2012/03/linux-dns-bind-configuration-on-centos-6-2/+broexperts+bind&cd=1&hl=en&ct=clnk&gl=mu

/etc/hosts

127.0.0.1 localhost
64.79.100.119 server.leech4ever.com server

/etc/resolve.conf

search leech4ever.com
nameserver 64.79.100.119

/etc/resolv.conf

nameserver 4.2.2.1
nameserver 4.2.2.2

How to solve this problem guys.....The tutorial was flawless until i did a server restore

share|improve this question

1 Answer 1

If the configuration files you posted are from the DNS server: there shouldn't be external resolvers in /etc/resolv.conf. The server is authoritative for itself, and forwarders are configured in the named configuration.

rm /etc/resolv.conf
mv /etc/resolve.conf /etc/resolv.conf

Then check if named is actually running and has a valid configuration.

ps -C named
named-checkconf /PATH/TO/named.conf
named-checkzone server.leech4ever.com /PATH/TO/YOUR/zonefile

Also check your logs to see if the zone was correctly loaded.

share|improve this answer
    
I tried the commands above but now i get connection timed out when i do nslookup .My domains are not propagating although i set nameservers –  Werulz Sep 4 '12 at 3:37
    
It's nice that you tried them. Would it hurt awfully to tell us which results they produced? If you want help you have to give us something to work with. –  Ansgar Wiechers Sep 4 '12 at 9:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.