Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having trouble configuring pgsql for PHP 5.2 on the server I administer.

It's a DirectAdmin enabled server, and the contents of ap2/configure.php5 are:

#!/bin/sh
./configure \
--with-apxs2 \
    --with-curl=/usr/local/lib \
    --with-gd \
    --enable-gd-native-ttf \
    --with-ttf \
    --with-gettext \
    --with-jpeg-dir=/usr/local/lib \
    --with-freetype-dir=/usr/local/lib \
    --with-kerberos \
    --with-openssl \
    --with-mcrypt \
    --with-mhash \
    --with-mysql \
    --with-mysqli \
    --with-pcre-regex=/usr/local \
    --with-pdo-mysql \
    --with-pear \
    --with-pgsql=/usr/pgsql-9.1 \
    --with-png-dir=/usr/local/lib \
    --with-zlib \
    --with-zlib-dir=/usr/local/lib \
    --enable-zip \
    --with-iconv=/usr/local \
    --enable-bcmath \
    --enable-calendar \
    --enable-ftp \
    --enable-magic-quotes \
    --enable-sockets \
    --enable-mbstring

When I check phpinfo() I get the following output:

'./configure' '--with-apxs2' '--with-curl=/usr/local/lib' '--with-gd' '--enable-gd-    native-ttf' '--with-ttf' '--with-gettext' '--with-jpeg-dir=/usr/local/lib' '--with-freetype-dir=/usr/local/lib' '--with-kerberos' '--with-openssl' '--with-mcrypt' '--with-mhash' '--with-xsl' '--with-imap=/usr/lib/dovecot/imap' '--with-imap-ssl' '--with-mysql=/usr' '--with-mysqli=/usr/bin/mysql_config' '--with-pdo-mysql=/usr' '--with-pear' '--with-png-dir=/usr/local/lib' '--with-zlib' '--with-zlib-dir=/usr/local/lib' '--enable-zip' '--with-iconv=/usr/local' '--enable-bcmath' '--with-mime-magic' '--enable-soap' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-mbstring'

Don't search, there's no mention of pgsql there...

What could be the problem? I'm not really used to DirectAdmin, but I'll have to deal with it.

Sergei

share|improve this question
    
. . . so what is your question/problem? –  voretaq7 Sep 3 '12 at 23:50
    
@voretaq7: he enabled pgsql when compiling but phpinfo() doesn't show it. –  quanta Sep 4 '12 at 3:31
    
After you run configure, there will be a config.log created. Can you do cat config.log | grep pgsql and see if there are any errors? –  Chida Sep 4 '12 at 5:21
    
are you sure you have postgresql dev headers installed? –  Hubert Kario Sep 14 '12 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.