Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Windows Small Business Server 2011

I have a file structure with a lot of sub folders (sometimes 5-6 levels deep). I have created access groups to grant access to my users, and also deny groups to deny access to others.

X Access & X Deny. These allow or deny access to a mapped network drive X:

On the server I put in the groups with Full Control Allow for X Access and Full Control Deny for X Deny, I also tick the box "Apple these permissions to objects and/or containers within this container only" and have ensured that "Apply to:" is "This folder, subfolders and files".

But for some reason the permissions will only apply to the next level of folders & files.

ex. structure:

X:

Folder 1

Folder 1a

Folder 2

Folder 2a

If I apply the permissions to X: it'll only go to Folder 1 & 2, not 1a and 2a, I then need to manually apply the permissions to these too.

Is this working as intended or am I doing something wrong?

share|improve this question
    
It might be helpful if you posted the output of cacls directory for each directory. –  Zoredache Sep 4 '12 at 4:08

2 Answers 2

up vote 2 down vote accepted

Depending on how you created your directory structure, you might have broken inheritance for some of your subdirectories. In this case, you should use the "reset permissions on all child objects and enable propagation" check box in the Advanced Access Control Settings dialog:

screenshot of the advanced access control settings

After doing this, you should see inheritance working again.

If you are not able to change ACLs due to permission restrictions, consider seizing ownership for X: and all files and subdirectories.

share|improve this answer
    
This somewhat was the issue. I needed to go and add the group to the permissions in the standard permissions box, then go into advanced and check "Reset permissions...". –  Jovin_ Sep 4 '12 at 7:04

FIX:

DO NOT TICK BOX for "Apply these permissions to objects and/or containers within this container only".

share|improve this answer
1  
Where does this check box exist? Accepted answer shows solution. Can you add details to your answer? –  Dave M Apr 2 at 21:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.