Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have supermicro X7DB8 motherboard. I have put in 16GB ram 2GB in each slot. It only recognizes 8GB. I know all the ram works because it was working in a different server. If I put 4GB RAM it only recognizes 2GB. I cannot figure out what is wrong

share|improve this question
    
Are you using both CPU sockets, or is only one being used? –  sysadmin1138 Sep 4 '12 at 11:26
    
1 cpu. How would i force it to use all the ram –  sharif Sep 4 '12 at 11:28
3  
You may not be able to! The last post on the thread I linked to indicates this. –  Rqomey Sep 4 '12 at 12:10
    
@sharif Try inserting only one stick and boot, continue to do this until you get 5 sticks, check the BIOS to see how many are being recognized. –  JMeterX Sep 4 '12 at 12:34
    
Post the specs of the RAM you're putting in. Speed, timing, how many ranks, FB/Registered, etc. –  MDMarra Sep 4 '12 at 21:09
add comment

5 Answers 5

up vote 2 down vote accepted

On recent biprocessor motherboards, half the RAM slots and half the PCIe slots are attributed to each CPU. If you only use one CPU, you can only use half the RAM slots and half the PCIe ports.

On older motherboards (such as the X7DB8) you need to insert the RAM stick in the proper order. See the documentation:

http://www.supermicro.nl/about/policies/disclaimer.cfm?url=/manuals/motherboard/5000P/MNL-0832.pdf

share|improve this answer
add comment

Some servers, such as HP, offer a type of RAM redundancy, which will swap in new RAM (already installed in the server) if it detects an error. Unlikely, but work checking if you have this feature enabled accidentally.

NOTE: In the online spare configuration, the ROM automatically configures the last populated bank as the spare memory. If only banks A and B are populated, bank B is the spare bank. If banks A, B, and C are populated, bank C is the spare bank, If banks A, B, C and D are populated, bank D is the spare bank, Online spare memory is configured through RBSU.

I believe in supermicro world it is called memory mirroring, and your MB supports it (see memory capacity section here, and some forum posts on it here

From HP DL360 G5 data sheet

share|improve this answer
    
I cannot find this option on the bios –  sharif Sep 4 '12 at 10:42
    
I updated my answer with a link, it is called memory mirroring in supermicro I think –  Rqomey Sep 4 '12 at 10:50
    
I have read the manual and checked the bios, the only thing i found is memory branch mode which is set to interleave and the spare memory bank are set to disabled. It is not the jumper settings either. –  sharif Sep 4 '12 at 11:03
add comment

You need to check the order of how the RAM should be inserted into the RAM slots, for this you'll need to check the server documentation. Most likely that you just didn't insert them in the right order - server hardware has such a feature that you need to follow such an order.

share|improve this answer
    
I have 8 slots and they are all have 2GB sticks, I don't think that should be a problem –  sharif Sep 4 '12 at 10:29
    
Then yes - something else might be wrong. Try checking the BIOS configuration. –  Logic Wreck Sep 4 '12 at 10:35
add comment

In the past I have noted some H/W incompatibility between different manufacturers of the identical type of RAM, same speed, same size and even between systems. Don't discount this type of issue.

share|improve this answer
add comment

Since you did not post the ram specs, this is only am educated guess, but something about the RAM is likely incompatible with the motherboard. Perhaps they're quad or dual ranked DIMMs and your motherboard doesn't support that?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.