Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is my driver information.

ethtool -i ethXX
driver: ixgbe
version: 3.9.15-NAPI
firmware-version: 0x800000a5
bus-info: 0000:04:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes

Now I have an average traffic of 1/1.5 Gbps (75k packets per second) hitting this interface and I can see one/or more of the ksoftirqd threads going to 100%.

I tried enabling the rx-usecs/rx-frames option, but no improvement. A bit of latency is not an issue for me. I just want the ksoftirqd usage to go down.

I see the limit of rx-usecs is 1022, which is the usecs after which the next interrupt should be fired (thats my understanding, please correct me if I am wrong). Though it doesn't solve my problem.

rx-frames on other hand are not supported on this driver. Neither is there any support for "adaptive-rx".

What should be the next step I should be looking at? Any help is greatly appreciated.

share|improve this question
    
What CPU do you have? And what version of irqbalance are you running? –  David Schwartz Sep 4 '12 at 11:27
    
@ David Its a 24 core machine. sample output from /proc/cpuinfo. processor : 23 vendor_id : GenuineIntel cpu family : 6 model : 44 model name : Intel(R) Xeon(R) CPU L5638 @ 2.00GHz I don't use irqbalance. Instead I have RSS enabled which distributes packets on 24 rx-queues and these queues are mapped to different cpus. –  pandagirija Sep 4 '12 at 11:51
    
What are you using to map the queues to CPUs? (Also, I think your hardware only supports 4 queues.) –  David Schwartz Sep 4 '12 at 12:02
    
Each of these rx-queues (eth-TxRx-0/1/..) have one irq line assigned to them (62/63/64/...). I am editing the smp_affinity bit map in /proc/irq/<irq_no>/smp_affinity which maps one queue to one cpu. I can see 24 eth-TXRX queues. –  pandagirija Sep 4 '12 at 12:06
    
Have you tried the newest drivers from Intel's site? I find them to solve a lot of problems, the drivers that come with distros tend to lag behind quite a bit, which causes issues with newer hardware. –  Marcin Sep 4 '12 at 12:49

1 Answer 1

Turn on rx-flow-hash if not already turned on for tcp4/udp4/tcp6/udp6 e.g.

ethtool -N ethX rx-flow-hash udp4 sdfn 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.