Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've tried configuring the IPMI controller to accept remote connections, but I can't even ping it.

Here is its status:

#/usr/local/bin/ipmitool lan print 2

Set in Progress         : Set Complete
Auth Type Support       : NONE PASSWORD
Auth Type Enable        : Callback :
                        : User     : NONE PASSWORD
                        : Operator : PASSWORD
                        : Admin    : PASSWORD
                        : OEM      :
IP Address Source       : Static Address
IP Address              : 192.168.1.112
Subnet Mask             : 255.255.255.0
MAC Address             : 00:a0:a5:67:45:25
IP Header               : TTL=0x40 Flags=0x40 Precedence=0x00 TOS=0x10
BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Enabled
Gratituous ARP Intrvl   : 8.0 seconds
Default Gateway IP      : 192.168.1.1
Default Gateway MAC     : 00:00:00:00:00:00
802.1q VLAN ID          : Disabled
802.1q VLAN Priority    : 0
RMCP+ Cipher Suites     : 0,1,2,3
Cipher Suite Priv Max   : uaaaXXXXXXXXXXX
                        :     X=Cipher Suite Unused
                        :     c=CALLBACK
                        :     u=USER
                        :     o=OPERATOR
                        :     a=ADMIN
                        :     O=OEM

# /usr/local/bin/ipmitool user list 2

ID  Name             Enabled Callin  Link Auth  IPMI Msg   Channel Priv Limit
1                    true    false   true       true       USER
2   admin            true    false   true       true       ADMINISTRATOR

# /usr/local/bin/ipmitool channel getaccess 2 2
Maximum User IDs     : 5
Enabled User IDs     : 2

User ID              : 2
User Name            : admin
Fixed Name           : No
Access Available     : callback
Link Authentication  : enabled
IPMI Messaging       : enabled
Privilege Level      : ADMINISTRATOR

# /usr/local/bin/ipmitool channel info 2
Channel 0x2 info:
  Channel Medium Type   : 802.3 LAN
  Channel Protocol Type : IPMB-1.0
  Session Support       : multi-session
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
  Volatile(active) Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : disabled
    Access Mode         : always available
  Non-Volatile Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : disabled
    Access Mode         : always available

# /usr/local/bin/ipmitool chassis status
System Power         : on
Power Overload       : false
Power Interlock      : inactive
Main Power Fault     : false
Power Control Fault  : false
Power Restore Policy : unknown
Last Power Event     :
Chassis Intrusion    : inactive
Front-Panel Lockout  : inactive
Drive Fault          : false
Cooling/Fan Fault    : false

# arp
Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.1.112            ether   00:A0:A5:67:45:25   C                     bond0

# /usr/local/bin/ipmitool -I lan -H 192.168.1.112 -U admin -P admin chassis power status
Error: Unable to establish LAN session
Unable to get Chassis Power Status

In summary. It exists on the ARP list so arp's are being broadcast. I can't ping it and can't connect to it. Can anyone spot any glaring mistakes in the configuration?

Many thanks, Fidel

share|improve this question
    
Is that machine on the internet? Brutally speaking: Fix your routing. This is a private IP - could well be the problem. –  TomTom Sep 4 '12 at 19:35
    
Thanks Tom, the machine is on a local lan. The ipmi queries and commands will also come from the local lan. Cheers –  Fidel Sep 5 '12 at 7:51
    
Fidel, does your IPMI has a separate NIC interface or share it? –  Serhiy Sep 6 '12 at 20:17
1  
To expand on Serhiy's comment: if it a shared NIC then ipmitool cannot be run on the the server itself. You must run it from a remote server. –  Mark Wagner Sep 6 '12 at 20:49
1  
Can you post a packet dump while you try to ping it and ipmiping it? –  MikeyB Sep 7 '12 at 14:02

3 Answers 3

As other people already stated, it may be a networking problem. You are supposed to be able to ping the BMC by default.

However, it could also be a more insidious issue caused by the BMC not taking the new configuration in account.

Try to reset the BMC: mc reset cold

I have experienced this problem on many Dell IDRAC-stuffed machines, and the reset always fixed it.

share|improve this answer
    
Thanks tux, I'm able to send instructions like "chassis power down" now but I can't tell it to power up. There aren't impiping responses when it's off –  Fidel Sep 13 '12 at 7:34
    
Can be due to the power saving mode, see lists.us.dell.com/pipermail/linux-poweredge/2009-February/… –  zecrazytux Sep 13 '12 at 8:20

In my experience it is necessary to set the default gateway MAC address in order to establish connectivity from the outside of your network. Also, if you are using link aggregation and have a shared port for the BMC, it brings other problems. On some switches it's possible to circumvent the load sharing algorithm for a MAC or IP address and direct the traffic to a specific port.

share|improve this answer
    
Milan, tell me more about the link aggregation and shared port. I'm also having issues similar to this. Can you not use link aggregation and shared ipmi? –  Matt Jan 29 '13 at 7:14

Could easily be a firewall issue on the target server (or inbetween). For example, do you see traffic arrive on UDP/623 (ipmi port) at the target server? Do you have iptables running, or SELinux, and if so, have you tried turning up logging to see what's going on?

One thing you can do to eliminate ipmi is to stop the listener service, then run a temporary listener like nc (netcat) and see if you can connect to it from a client (you can use netcat again here too). Start local and then expand outwards.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.