Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to optimise a website and I was using the network waterfall facility in Google Chrome. When I looked at the results there were lots of files which I didnt recognise. I first thought they might be something to do with Google Chrome itself, so I put a blank HTML file on my desktop and checked but there was nothing in the waterfall except the file itself. So I put a blank file on my server and I got the output below. What are all these files, are they all necessary, is this normal and do I need to be in any way concerned. My hosting provider has always been excellent in every regard that I'm aware of.

My host is shared hosting, using cpanel and is based on a LAMP server.

I also note that a couple of those file have problems but I have no idea how to fault find that or whether it's a concern.

EDIT: I have cleared the cache so I don't think it's a browser cache issue.

enter image description here

share|improve this question
    
Stupid question but have you cleared the browser cache? –  Brent Pabst Sep 4 '12 at 19:01
    
:-) No it's a good question. It was a new file so I hadn't but I cleared it now and (I think the exact) same result. Will update my question. –  byronyasgur Sep 4 '12 at 19:08
    
And you are trying this with just a blank Hello World html file? The browser should not be requesting other resources unless the page tells it to do so. –  Brent Pabst Sep 4 '12 at 19:10
    
Totally blank file. I created it in cpanel. When I click CTRL U it's a blank file. –  byronyasgur Sep 4 '12 at 19:11
    
OH... There it is: CPanel. Run view source on this "so-called" blank file and update your question with it. $5 says CPanel is creating a "page" with pre-determined content it thinks you might need. –  Brent Pabst Sep 4 '12 at 19:13

3 Answers 3

I'd look at the website access file itself. That is a better indicator of what is being sent to a specific ID. I'd suggest what you are seeing is browser related and not website related but going to the horses mouth is the best approach.

share|improve this answer
    
Sorry what exactly do you mean by 'Website access file' –  byronyasgur Sep 4 '12 at 19:13
    
The web server itself (i.e. apache in most cases). There is a file generated for all accesses by any IP number that would be the best source. If it is disabled, enable it. –  mdpc Sep 4 '12 at 19:15
    
that gave me an idea. I forgot I should try my local webserver. I have mamp on my machine and lo and behold when I put blank file from my desktop in there it shows those strange files too. Same file, so something to do with being on a server, even though it's a different servver ( mamp out of the box ) .... but it's weird because this doesn't happen with Firefox/Firebug –  byronyasgur Sep 4 '12 at 19:19
up vote 0 down vote accepted

It turned out to be a combination of two chrome browser extensions. One of them was an extension called Fast Save which looks like it I might have been tricked into installing http://www.fergeeks.com/chrome-tips/fast-save-1-1-chrome-extension-adding-ads-causing-havoc/ but the other was the popular lastpass extension.

share|improve this answer

This question is completely off topic but something resulting in a blank page can involve many requests for the web server. If you have a look at the files involved you'll notice that nearly all produce no output on their own. As for the rest, they may not be displayed if there is an error in your code. Just because an image is requested does not mean it will be displayed. If it's not displayed it won't show in the resultant "source" code. e.g. Images may be requested because they are used in your JavaScript, ready to be displayed on some event or other.

share|improve this answer
    
Not sure what you mean TBH ... all the files produced a lot of output ... I had no code ( blank file ) .... there is nothing in my source code no matter what way you cut it ... I dont have any javascript ( or anything else for that matter ) ... TBH I'd downvote this if I was over 125, sorry :-( ... I discovered the problem anyway... see my answer which I can accept tomorrow. I think it's quite relevant as many people who may be doing server optimisation may use last pass and be puzzled about these resutls (which are easily removed by disabling last pass ... and in my case removing 'Fast Save') –  byronyasgur Sep 5 '12 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.