Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to change locale in CentOs 6.3 to English. But after changing, only root account have English interface... Another user still have Russian interface. But I changed locale to:

LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"

inside /etc/sysconfig/i18n file. Also i tried to change it using GUI utility - system-config-language. After changes I always reboot my machine. Nothing help.

Thanks.

share|improve this question
    
Is this a workstation where you are logging in at the desktop, or a server where you log in from console or remotely? –  Michael Hampton Sep 5 '12 at 5:45
    
@MichaelHampton yes, is workstation at desktop, i.e. I want to change GNOME interface language. I run CentOS 6.3 on VMware Workstation 8 on Windows –  MyTitle Sep 5 '12 at 5:48

1 Answer 1

up vote 1 down vote accepted

Each user can have his own language settings. So when a user goes to log in, the language changes to whatever language he used previously.

So for a user to change his language, he should first click his username in the list on the login screen, but do not type the password yet. Then go to the bottom center of the screen to change the language to the desired language he wants.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.