Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server turning on Plesk 10.4.4 and I want to upgrade it to 11.0.9.

When I use the online upgrade tool, I have this warning:

Parallels Panel pre-upgrade check... WARNING: You have a mixed set of 'php' and 'php53' packages installed. Installation or upgrade may fail or produce unexpected results. To resolve this issue run "sed -i.bak -e '/^\s*skip-bdb\s*$/d' /etc/my.cnf ; yum update 'php*' 'mysql*'". PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0

I have run the code in ssh, but nothing changes.

I have already searched all package names with "php", and I have this list:

# yum list installed | grep php
php-common.i386                              installed
php-pear.noarch                      1:1.4.9-8.el5                     installed
php5-ioncube-loader.i386             4.0.7-11062118                    installed
php53.i386                           5.3.3-13.el5_8                    installed
php53-cli.i386                       5.3.3-13.el5_8                    installed
php53-devel.i386                     5.3.3-13.el5_8                    installed
php53-gd.i386                        5.3.3-13.el5_8                    installed
php53-imap.i386                      5.3.3-13.el5_8                    installed
php53-mbstring.i386                  5.3.3-13.el5_8                    installed
php53-mcrypt.i386                    5.3.3-1.el5                       installed
php53-mysql.i386                     5.3.3-13.el5_8                    installed
php53-pdo.i386                       5.3.3-13.el5_8                    installed
php53-sqlite2.i386                   5.3.2-11041315                    installed
php53-xml.i386                       5.3.3-13.el5_8                    installed
psa-appvault-phpads.noarch           2.0.8-8203520080409011611         installed
psa-appvault-phpbb.noarch            3.0.0-8200820080409011626         installed
psa-appvault-phpbook.noarch          1.50-8203220080409011638          installed
psa-appvault-phpbugtracker.noarch    1.19-8203820080416050605          installed
psa-appvault-phpdig.noarch           1.85-8203120080409011645          installed
psa-appvault-phpmoney.noarch         1.3-8204320080409011649           installed
psa-appvault-phpmyfamily.noarch      1.4.1-8203420080409011655         installed
psa-appvault-phpmyvisites.noarch     2.3-8202820080409011701           installed
psa-appvault-phprojekt.noarch        5.2-8200820080409011713           installed
psa-appvault-phpsurveyor.noarch      0.98-8204320080409011723          installed
psa-appvault-phpwebsite.noarch       0.10.2-8203420080409011738        installed
psa-appvault-phpwiki.noarch          1.3.11-8204320080409011808        installed
psa-php53-configurator.i386          1.6.1-cos5.build1013111101.14     installed

After verification in the Plesk file: panel_preupgrade_checker.php

I think the warning is due to these lines:

(from : panel_preupgrade_checker.php)
foreach ($packages as $package) {
       $name = $package['name'];
       $hasPhp5  |= ($name == 'php' || strpos($name, 'php-') === 0);
       $hasPhp53 |= (strpos($name, 'php53') === 0);

Now, I think the problem is just due to the names of theses packages:

php-common.i386                              installed
php-pear.noarch                      1:1.4.9-8.el5                     installed

Can you help me to resolve this situation?

This is my repolist :

PPB_10_4_4-dist                                                   Parallels product PPB_10_4_4 dist                                                            2
PPB_10_4_4-thirdparty                                             Parallels product PPB_10_4_4 thirdparty                                                      0
PSA_10_4_4-thirdparty                                             Parallels product PSA_10_4_4 thirdparty                                                      2
SITEBUILDER_10_4_4-dist                                           Parallels product SITEBUILDER_10_4_4 dist                                                    3
base                                                              CentOS-5 - Base                                                                         2722+3
epel                                                              Extra Packages for Enterprise Linux 5 - i386                                              5800
extras                                                            CentOS-5 - Extras                                                                          282
plesk                                                             Plesk Server Administrator                                                               141+1
updates                                                           CentOS-5 - Updates                                                                       797+4
repolist: 9749


I have make the update , because, i think the warning is not really bad ( the warning came from a pakage name not matching )

And finaly it's work !

share|improve this question
yum repolist? – quanta Sep 5 '12 at 15:33
Yeah, it looks like that php-common package came from the "Atomic" repo (which is not in your repolist). While they may have been careful in packaging it, it's generally not safe to mix and match repo sources for things as delicate as PHP. You probably want to either switch entirely to their PHP packages, or switch entirely to those provided by your existing repos. – Charles Sep 6 '12 at 16:08

I just had this problem, a bit more difficult though because I wanted to setup to use PEAR in SSH other scripts not in my domains httpdocs.

If you have installed PEAR on PLESK but tested it and it's not working, include the following, for each domain you wish to use PEAR, in






php_admin_value open_basedir "/var/www/vhosts/" php_admin_value include_path ".:/usr/share/pear"

Also make sure it is in php.ini (THE RIGHT ONE: one is for public_docs and the other is for root docs. If it is not there add include_path ".:/usr/share/pear/

share|improve this answer

You can forcefully erase the troublesome packages. Try running

rpm --erase --nodeps php-common php-pear

and try your update again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.