Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Varnish throws an error message when I try to restart it:

/etc/init.d/varnish restart
/etc/default/varnish: 90: -s: not found
/etc/default/varnish: 90: -s: not found
Stopping HTTP accelerator: varnishd.
/etc/default/varnish: 90: -s: not found
Starting HTTP accelerator: varnishd.

This is my default.vcl:

backend default {
    .host = "127.0.0.1";
    .port = "8080";
}

And this is my Varnish file within the default configuration:

DAEMON_OPTS="-a :80 \
         -T localhost:6082 \
         -f /etc/varnish/default.vcl \
         -u varnish -g varnish \
         -S /etc/varnish/secret \
         -s malloc,1G"

Nginx is working as a web server and listening to port 8080. It works with an static HTML file but not with PHP files. php5-fpm is installed and all services are running.

share|improve this question
    
What does /etc/default/varnish look like? Is that the file with the DAEMON_OPTS file in it, or is that a different file? –  larsks Sep 5 '12 at 12:09
    
Correctly. I've extended the DAEMON_OPTS and the error is going away ;) But the problem with the php files is still alive. have you got an idea what i can do to run php files? –  derpiet Sep 5 '12 at 12:10
    
which version of varnish are you using? –  Mike Sep 5 '12 at 13:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.