Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

EDIT:

I have found a solution, even if we can't talk exactly of solution. Well, I used RevoUninstaller to remove the MySQL Server, then I've proceed with a standard installation and everything got solved. Then, I've repeated all the steps above, adding each time a customization. I finally found that the error comes out when I chose default character set to ucs2 instead of latin1. Even If the problem is solved, I'll leave the question open for further and more detailed answers.

END EDIT.

I've tried to update MySQL Server from version 5.1 to 5.5 to get rid of a bug in a program. After a first try, the situation was worst than I have expected: the program can't log in with root user anymore and so Workbench and console. In the latter case, the error was:

c:\mypathtosql>mysql -u root -p
Enter password:******
ERROR 1045 (28000):

Yes, after ERROR 1045 (28000) there were no details. I decided to completely remove the package (which include a manual removing of all reg keys) and then to install it again. This workaround worked for Workbench, but my program can't do the user creation from a script with no error apparently (I get an error "Can't find any matching row in the user table", but I guess this happen late in the script when I log with the appropriate user), and also the console persist to give the error described above.

Everything seems to work fine with MySQL Workbench...

Hints, suggestions?

Thank you in advance.

share|improve this question

2 Answers 2

You can just reset the mysql root password, here are some links showing how to do that:
http://dev.mysql.com/doc/refman/5.0/en/resetting-permissions.html
http://www.cyberciti.biz/tips/recover-mysql-root-password.html

share|improve this answer
    
I've tried both links but nothing to do. Please, take a look to my edit. Thank you anyway. –  IssamTP Sep 6 '12 at 13:02
    
You need to start mysql with skip-grant-tables as described in the links above, from there you either need to reset the root password or create the root user(in case it doesn't exist which I very much doubt), this will help you. –  Logic Wreck Sep 6 '12 at 13:07

I know this question is already gone out of our concern, because it's 1 years old. But I want to leave some information what I found to let help someone who get pain with this problem like me or us.

I've suffered with this problem and after reinstalling MySQL 5.5 sometimes, I found a solution. This is not a problem with any permission(incl flush permissions) or password reset.

Simply, the problem is 'ucs2' on windows version of MySQL client application(mysql.exe).

To logon normally, you need to modify your my.ini file.

  1. Open my.ini in your MySQL installation path
  2. Find 'default-character-set' in [mysql] section.
  3. It's value would be 'ucs2'. Modify its value to 'utf8' or 'latin1' and save.

After this, you would be able to logon to your MySQL instance.

share|improve this answer
    
I didn't found the exact reason of this, but I guess that MySQL client application seems to convert our input(id/pass) from console from default-character-set to utf8. Regardless of what we chose as a default character set while installation(exactly MySQLInstanceConfig.exe), all string columns except Password in 'user' table in 'mysql' db is created as 'utf8' encoded. And of course, to compare two strings, they need to converted in the same character set. Character set using multibytes to store English letters like utf16/32 didn't worked too. But, it's only a guess, not fact. ;) –  Codeption Dec 2 '13 at 11:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.