Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to reset my firewall password so that I can do a factory reset on it.

I bought it used and the rules are more restrictive than I want. It's being used for a small project where we can demonstrate a bad configuration.

I am following the Cisco PIX Password Recovery Guide as the basis for my procedure.

These are the steps that I followed:

  1. Turn off wireless
  2. Go to my LAN network options and click on ipv4 options
  3. Set the ip and DNS, click ok
  4. Start a tftp server on the ip
  5. Connect the firewall via ETHERNET to my laptop (I also have the console serial connected)
  6. Go into my terminal and type address, this is the ip I want for the firewall
  7. Then I type server, ip of my comp/server
  8. I use the command ping to test the connection and it says 0/5 successful
  9. I tried using the tftp command to get the file I needed, but it just hung forever

What could I be doing wrong?

I checked out wireshark to see what was happening with the 'tftp' command and it would always say port unreachable. I am using port 69 on my tftp server, if the ping command didn't work the tftp command probably isn't going to work either

The firewall is connected DIRECTLY to laptop via ETHERNET. I tried using interface 0, but it failed. Interface 1 worked just fine. I don't know if this makes a difference or not.

I am going to try to put a router in between the two to see if it will help me at all

share|improve this question

migrated from Sep 6 '12 at 15:47

This question came from our site for information security professionals.

This could be windows firewall blocking the connections – resmon6 Apr 20 '12 at 12:30
While this is about a device that provides security-related functions on a network, I'm not seeing a question that's actually about security here. Maybe Server Fault might be a better place for this. I've flagged it for migration - please don't cross-post. – Iszi Sep 6 '12 at 14:24
This is more about device configuration, albeit a traditionally security device. This is really a better fit for our sister site for Information Technology Professionals, Server Fault. – Scott Pack Sep 6 '12 at 14:32

I've only worked on the ASA series firewalls and this is the procedure I use: I believe it will work on the PIX as well.

Either way you can always call the TAC and they will walk you threw it step by step.

share|improve this answer
I'm trying to use 192.168.1.*, should it be or do I need to use a router and switch? – Hal Jordan Apr 21 '12 at 1:37

Ideally, you would have a switch between your computer and the firewall, but a direct connection should work.

You need to change the IP address of your computer to 192.168.1.* This could definitely cause the issues you described. By specifying as the netmask, you told the computer that the entire network consists of only 1 IP address. Even if it successfully receives tftp traffic from the PIX, your computer won't know how to respond since there are no other devices on your interface's network.

Also, be sure to turn off, or properly configure your desktop firewall.

You would probably get more feedback for this question on or

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.