Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a computer joined to the domain, but it doesn't view the network "location" as being part of the domain. I have tried removing and rejoining the domain and this doesn't help:

enter image description here

Other computers in the same network don't have this problem. I have also tried several different icons, including both the train and the airplane which doesn't seem to make a difference.

At least using nslookup, the server seems to have connectivity with the DCs in the same site. There also seem to be some errors that suggest a NULL domain:

Computer: OR-WEB05.ds.stackexchange.com
Description: NtpClient was unable to set a domain peer to use as a time source because of failure in establishing a trust relationship between this computer and the '' domain in order to securely synchronize time. NtpClient will try again in 3473457 minutes and double the reattempt interval thereafter. The error was: The trust relationship between this workstation and the primary domain failed. (0x800706FD)

share|improve this question
    
I've seen this issue with clients before as well, normally its just a matter of the client getting the proper DNS info from the server. Any NETLOGON errors with codes such as 5722, 5723, or 3210? –  Brent Pabst Sep 13 '12 at 19:59

1 Answer 1

That error suggests you could have a bad computer password. Can you remove and readd to domain without breaking server apps? (don't know what's on the server).

The icons for Network Location are purely aesthetic.

Note there is a hotfix that may resolve your NLA issue.

More info on NLA.

Network Location of "Domain" is determined by DNS search suffix and AD connectivity. To ensure DNS isn't the issue, and assuming since it's a server, that you've set IP statically: you need to ensure the TCP/IP DNS settings have the same DNS suffix as the AD DNS domain. Normally you leave this blank in the NIC IPv4 DNS tab and let the computer domain membership match your DNS server settings (System -> Advanced System Settings -> Computer Name -> More -> "Primary DNS suffix of this computer"). Just pair up this setting and NIC settings to a work server to be sure they are correct.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.