Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can anyone shed some light on what exactly this error refers to?

I'm having trouble deploying new versions of the site.

I,  INFO -- : reloading config_file=[snip]/current/config/unicorn.rb
I,  INFO -- : Refreshing Gem list
E, ERROR -- : error reloading config_file=[snip]/current/config/unicorn.rb: Application has been already initialized. (RuntimeError)
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/railties-3.2.3/lib/rails/application.rb:135:in `initialize!'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/railties-3.2.3/lib/rails/railtie/configurable.rb:30:in `method_missing'
E, ERROR -- : [snip]/releases/20120907085937/config/environment.rb:5:in `<top (required)>'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in `require'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in `block in require'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:236:in `load_dependency'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in `require'
E, ERROR -- : config.ru:4:in `block in <main>'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `instance_eval'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `initialize'
E, ERROR -- : config.ru:1:in `new'
E, ERROR -- : config.ru:1:in `<main>'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn.rb:44:in `eval'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn.rb:44:in `block in builder'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn/http_server.rb:696:in `call'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn/http_server.rb:696:in `build_app!'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn/http_server.rb:677:in `load_config!'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/lib/unicorn/http_server.rb:303:in `join'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/gems/unicorn-4.3.1/bin/unicorn:121:in `<top (required)>'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/bin/unicorn:23:in `load'
E, ERROR -- : [snip]/shared/bundle/ruby/1.9.1/bin/unicorn:23:in `<main>'
I,  INFO -- : reaped #<Process::Status: pid 3182 exit 0> worker=0
I,  INFO -- : reaped #<Process::Status: pid 3185 exit 0> worker=1
I,  INFO -- : reaped #<Process::Status: pid 3188 exit 0> worker=2
I,  INFO -- : reaped #<Process::Status: pid 3191 exit 0> worker=3
I,  INFO -- : worker=0 ready
I,  INFO -- : worker=3 ready
I,  INFO -- : worker=1 ready
I,  INFO -- : worker=2 ready

Unicorn.rb

root = "/home/[user]/apps/[site]/current"
working_directory root
pid "#{root}/tmp/pids/unicorn.pid"
stderr_path "#{root}/log/unicorn.log"
stdout_path "#{root}/log/unicorn.log"

listen "/tmp/unicorn.[site].sock", :backlog => 2048

worker_processes 4

preload_app true

timeout 30

before_fork do |server, worker|
    defined?(ActiveRecord::Base) and ActiveRecord::Base.connection.disconnect!
end

after_fork do |server, worker|
    defined?(ActiveRecord::Base) and ActiveRecord::Base.establish_connection
end

Any help appreciated - I can pull more config files if required.

share|improve this question
1  
Issue resolved. Information over on StackOverflow: [here][1] [1]: stackoverflow.com/questions/12316302/… –  Andy Copley Sep 19 '12 at 20:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.