Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to access X11 my CentOS 6 x32 small Linode VPS through SSH Putty/Xming (enabled X11 forwarding on options).

My windows machine is not the problem since it works with others CentOS Servers.

X11Forwarding is enabled on /etc/ssh/sshd_config, still I can't get X11 forwarding.

I'm trying to get xclock to work, but I get Can't open display :0.0 error.

I've also tried with different $DISPLAY values like :0 or :10.0

I've tried MobaXterm, and I get this message when connecting:

X11 forwarding request failed on channel 0
share|improve this question
1  
What X server did you install on your Windows machine? –  Michael Hampton Sep 7 '12 at 16:14
    
Not sure what the CentOS equivalent is, but have you install the xbase-clients? This should include xauth, and a few other required libraries? –  Zoredache Sep 7 '12 at 16:35
    
I did yum install xclock, installed lot of dependencies. –  jacktrades Sep 7 '12 at 16:38

2 Answers 2

up vote 5 down vote accepted

Here (Red Hat Login required) is a Tech Brief article from a fellow Red Hat consultant which discusses the minimum packages needed for X-Windows to work for SSH connections.

The key points are:

1) Install the following:
xorg-x11-xauth
xorg-x11-fonts-*
xorg-x11-utils
2) Enable the following in the sshd_config file
X11Forwarding yes
3) Use an appropriate X-Server on your desktop
share|improve this answer

Installed this package: xorg-x11-xauth

Got solution from here.

Thanks for your help!

share|improve this answer
2  
The bug report was helpfull ! The solution for me was to change the sshd_config to read AddressFamily inet as I had deactivated ipv6 via sysctl... –  Julien Nov 1 '13 at 10:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.