Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm setting up a new web server that hosts a dozen virtual hosts on Ubuntu 12.4 using Apache 2.2.22 with one config file per site. I created all the configuration files all at once and ran a2ensite * to enable them all at once. When I reloaded the configuration it failed and after restarting apache I found the following error message in my error.log:

Oops, no RSA or DSA server certificate found for 'server.host.name:0'?!

Most of the results for this error message are years old that don't fix the problem or are bugs that have been fixed https://issues.apache.org/bugzilla/show_bug.cgi?id=31709

share|improve this question
up vote 4 down vote accepted

The problem ended up being in a different configuration file than the host that was listed in the error. It was due to the fact that there were duplicate ServerName values in two of the files. I fixed the wrong one and it started back up (bye bye that half an hour) :-) .

To troubleshoot this I disabled all the sites and then enabled a couple at a time until I ran into the problem again.

share|improve this answer

From: http://www.clearchain.com/blog/posts/solving-the-apache-ssl-error-oops-no-rsa-or-dsa-server-certificate-found-for-www-somedomain-com0

Summary: This error may also occur if you forget the following line in your VirtualHost section:

SSLEngine on
share|improve this answer

FWIW, I just ran into this issue again, under a different guise.

If you are using wildcard SSL certificates, ensure that the VirtualHost entry for the domain (domain.com) is listed before anything else (foo.domain.com, bar.domain.com, etc).

I tried the one-at-a-time config thing, and everything else ran fine until I added the this one file back in.

Then I twigged on that the config filename was lower alphabetically than the config file with the "primary domain definition". Changed the symlink so that it was placed after the main def and everything worked like a charm.

Example fail listing order:

foo.domain.conf
prim.domain.conf
something.domain.conf

Working example listing:

prim.domain.conf
something.domain.conf
zfoo.domain.conf

HTH someone else :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.