Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have 2 servers, 1 already configured with .net which works fine and a new one which appears to be configured the same but when I open an xml page in Internet Explorer it complains about the <% tag.

We have IIS on win srvr 2003 SP2. The website is configured with .NET 1.1.4322. In ISAPI extensions have set the .XML extension to use c:\windows\microsoft.net\framework\v1.1.4322\aspnet_isapi.dll

But the page:

<property name="documentmaxage" value="0"/>
<property name="documentmaxstale" value="0"/>
<var name="m_Prompt_Path" />

<form id="InitVoiceXmlDoc">
    <block>
        <assign name="m_Prompt_Path" expr="&quot;<% Response.Write(Request.QueryString["m_Prompt_Path"]); %>&quot;"/>
    </block>
</form>

gives the error:

The XML page cannot be displayed Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


The character '<' cannot be used in an attribute value. Error processing resource 'http://localhost:11119/fails.xml'. Lin...

&quo...

We have the same config on another server which works fine. So are there other options apart from the ISAPI extensions that I need to look at.

If I suffix the page .aspx, of course it works fine.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.