Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have ran into a problem and I dont get a clue of whats happening. I am trying to access my localhost but for some reason apache is crashing endlesly.

    Sep  9 19:06:40 mothership com.apple.launchd[1] (org.apache.httpd[7396]): Exited with code: 1
    Sep  9 19:06:40 mothership com.apple.launchd[1] (org.apache.httpd): Throttling respawn: Will start in 10 seconds

Any help would be much appreciated.

here is my system.log https://dl.dropbox.com/u/3230707/system.log

share|improve this question

closed as too localized by rnxrx, John Gardeniers, Ward, Lucas Kauffman, Ladadadada Oct 30 '12 at 11:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Are any useful messages in apaches error.log? –  Gerald Schneider Sep 9 '12 at 11:44
    
the only thing I know is thats related to apache. I have attached the system log file. –  Subash Sep 9 '12 at 11:49
    
Look in apache's error log: /var/log/apache2/error_log; that'll have much more relevant info than the system log. –  Gordon Davisson Sep 9 '12 at 17:02
add comment

1 Answer

i had the same problem, if i run

sudo apachectl -t

i get :

httpd: Syntax error on line 117 of /private/etc/apache2/httpd.conf: Cannot load /usr/libexec/apache2/libphp5.so into server: dlopen(/usr/libexec/apache2/libphp5.so, 10): Library not loaded: /usr/lib/libpq.5.dylib\n Referenced from: /usr/libexec/apache2/libphp5.so\n Reason: image not found

it says it can not find "/usr/lib/libpq.5.dylib" so i simlinked with :

cd /usr/lib

sudo ln -s libpq.dylib libpq.5.dylib

share|improve this answer
    
Could you clarify how this is (a) the same problem as the original poster's extremely vague question, and (b) a helpful answer? –  pjmorse Oct 8 '12 at 11:05
    
i had the same error in system.log but you are right maybe it is not exactly the same cause. At least the original poster can see that if he run "apachectl -t" he can have more details on his problem –  atrepp Oct 9 '12 at 13:10
    
It is an helpful answer because it helps to find out what (and where) the error is occurring. In my case, the apache error_log wasn't getting logged - it was going to the system log, similar to the question from OP –  dakdad Apr 5 '13 at 17:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.