Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to connect a Samsung TV to the Internet using a TL-MR3020 personal wireless router in client mode. The TV fails to connect to the network. It sees the ethernet cable connected though.

Here's my network topology:

my network topology

Here's what I've captured with Wireshark filtering for ARP (eth.type == 0x0806):

Wireshark capture

It appears the TV fails to get the IP of the gateway (DSL modem/router) for some reason. One thing I've noticed is that the source MAC for the ARP requests coming from the TV is the MAC of the Portable wireless router (that is cd:89:00), not the TV itself and the modem sends the responses to that MAC (I'm not an expert and don't know if its okay or it may make the TV fail to get the requested IP).

Also I'm able to ping the TV from the DSL router (through the telnet interface) and the router has an entry in its MAC table for the TV's IP with the Portable wireless router's MAC (that is cd:89:00). If I'm able to ping the TV I suppose it should know the router's MAC to respond to the ping, but then why these continuous ARP requests...

I've also tried to connect my desktop trough this Portable wireless router the same way I'm trying to connect the TV and it works fine, I can set the DSL Modem's IP as the default gateway on the desktop's NIC and connect to the Internet.

The TV can connect to the Internet when connected to the DSL Router with a wired connection.

Any suggestions on what may be the cause of the problem / how to further debug it are welcome.

Thanks!

share|improve this question
    
shouldn't the 2nd wireless router not just be a repeater? –  ott-- Sep 9 '12 at 15:33
    
In my understanding if it was a repeater there should be a third Wi-Fi device connected to the TV and the Portable router would just mediate between the two, is this correct? If you mean that the portable router should not hide the MAC of the TV then I have not found such a mode in the settings, the only mode I can specify the SSID to connect to is the so called Client mode. –  axk Sep 9 '12 at 16:14
    
You had the tv already running when you connected to the first AP by cable. That's why I thought that your TL-MR3020 should act as repeater (if it is capable of that). –  ott-- Sep 9 '12 at 23:40
    
BTW from the documentation I was under the impression what you refer to as "repeater" could be called "bridge" in the manual. –  scherand Sep 10 '12 at 5:53
add comment

1 Answer

Not sure if this would be better suited for superuser.com (i.e. home set up)?

Anyway: what exactlty is not working? How do you know the TV cannot connect to the Internet because it cannot "find" the default gateway and not because of something else?

From your description I think it could be perfectly possible that the problem is not layer 2 related.

You say

One thing I've noticed is that the source MAC for the ARP requests coming from the TV is the MAC of the Portable wireless router (that is cd:89:00), not the TV itself

and

I've also tried to connect my desktop trough this Portable wireless router the same way I'm trying to connect the TV and it works fine, I can set the DSL Modem's IP as the default gateway on the desktop's NIC and connect to the Internet.

Now how is that if you connect your PC? Do you also see the MAC of the wireless router? This would tell you if it is OK or not (I guess it might be OK).

share|improve this answer
    
I though about Superuser but I'm not sure if the ARP stuff is appropriate there, this may be a typical setup though. I understand this may be more trivial an issue and not layer 2 related, I just haven't found a better way of debugging this than sniffing the network yet. I'll check what the MAC is with the desktop connected, I think it should also be the Portable router's MAC. –  axk Sep 9 '12 at 16:24
    
Nothing wrong with sniffing network traffic, I guess. It might just not be a layer 2 but a layer 3 issue. To me, the excerpt of your dump (screen shot) looks OK. If 192.168.1.61 is your TV (and only your TV :)) ARP is working. Do you agree? I would then just sniff any traffic coming from/going to 192.168.1.61 and see what you get. –  scherand Sep 10 '12 at 5:56
    
The ARP traffic appears to be the only traffic I get from the TV. –  axk Sep 10 '12 at 10:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.