Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We recently upgraded to SBS2011 and my XP clients are receiving this error when our in house application attempts to copy files from the server:

You were not connected because a duplicate name exists on the network

In an effort to plan for future separation of the required resources for our business software I have set up separate DNS A records that all point to the same server. For example, I have "ApplicationDeployments" and "ApplicationDatabase" that both point to the same IP. I've noticed that Windows created many records in a similar fashion ("connect", "CompanyWeb", "SBSConnectComputer", "SharepointSMTPServer", etc.) that all point to the same IP address and this doesn't appear to create any issues

I've researched the error and tried most of the suggestions that are out there, here is what I've tried:

  1. Changing PMDApplicationDeployments from an A-record to a CNAME record – no change
  2. Adding the registry entry that you will find mentioned on the net ("DisableStrictNameChecking") – no change
  3. Removing and re-adding from the domain one of the XP machines that is exhibiting the problem – no change
  4. Renaming one of the XP machines that is exhibiting the problem – no change
  5. Deleting the auto-generated DNS A records – no change
  6. Restarting DNS server after any changes – no change

I have verified that:

  1. I can ping the server by the various host names
  2. I can navigate to the server in explorer using the various host names

UPDATE: Figured out simpler steps to reproduce the problem. From an XP Pro machine, if I try to navigate to the server using a host name that is different from the server machine name I will get this error. For example, let's say the machine name is "SERVER01" and I have created an A record called "AppServer" that points to the same IP as SERVER01. If I Start > Run > "\AppServer" I will receive the error:

You Were not connected because a duplicate name exists on the network

share|improve this question
1  
I had an issue similar to this, it turned out to be that the hostname of the old server was the same as the domain name in the new network, and that it was online at the same time. Although I wasn't using the old server for DNS, it was broadcasting it's name in netbios, and seeing as XP still uses netbios it was referring to this instead of the domain controller and getting confused. Ensure there are no servers on the network on the old domain and, if they are, disable netbios or turn off the server, then try again. –  Alex Berry Sep 10 '12 at 10:47
    
@Alex - thanks for the suggestion. Our situation is different, however I still took the other server down just to rule that it was creating the problem. Unfortunately nothing changed and the problem has persisted. –  Steve K Sep 10 '12 at 21:11
1  
I still believe it might be netbios, seeing as it only affects XP machines, try doing "nbtstat -a hostname", replacing hostname with the A record of the machine you're trying to access, and see what it comes back with. –  Alex Berry Sep 11 '12 at 8:08
    
"nbstat -a sites" returned "Host not found." –  Steve K Sep 11 '12 at 12:55
    
"nbstat -a server01" (actual machine name) returned what appears to be a valid response: "NetBIOS Remote Machine Name Table" with 5 entries (machine name and domain name) and the MAC Address. –  Steve K Sep 11 '12 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.