Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently taken over management of a server running centos and whm. It has several websites and domains running under reseller accounts. Email has always been on a server at our actual office. I have recently changed our email from our local email server to gapps for business (our local email server was pretty archaic).

However, when any email is sent from the web server (such as wordpress etc) to our domain - it still routes it to the IP of our old email server. I am not very familiar with WHM or exim so don't really know how to address this. Email to other domains works fine and the gapps is working perfectly.

Any help is much appreciated.

share|improve this question

2 Answers 2

You need to change your DNS records for the domain which you had changed the MTA for, the gapps MX records should be like described at http://support.google.com/a/bin/answer.py?hl=en&answer=33915

share|improve this answer
    
the gapps isn't the problem- it's working fine. somewhere on the webserver it has got a setting to send mail for our domain to our old server IP. I know this as the old server is still on, and any email sent to our domain from the webserver is still appearing in the old mailboxes –  Chris Bull Sep 10 '12 at 11:40
    
I see, in this case check this link - liquidweb.com/kb/understanding-localdomains-and-remotedomains - likely you'll have to change the option from Local to Remote Mail Exchanger. –  Logic Wreck Sep 10 '12 at 11:43
    
hmm i have tried all this, but the thing that i am noticing different to other email addresses (not within our domain) is that when viewing the mail delivery reports with WHM, emails to other hosts show the use of router lookuphost but ones to our domain show the use of router domain1send , with the delivery host and IP still that of our old email server –  Chris Bull Sep 10 '12 at 12:31

Regarding Logic Wreck's comment about the "localdomains and remotedomains" files, those are what Exim (MTA) checks against to tell if incoming email for the domain should be handled on the server or not.

Also, to come back to Logic Wreck's first suggestion, DNS is usually the cause of issues like this. Is DNS for the domain resolving to the webserver itself? Doing a dig from the webserver itself might indicate it's seeing something else for the MX record, if there is an issue.

$ dig domain.tld mx

Have you submitted a support request to cPanel? I would suggest doing so if you haven't sorted the issue.

share|improve this answer
    
I managed to fix this yesterday after a lot more digging - turns out in the exim advanced config there is a router configuration section to configure domain specific relay hosts - this is where our domain and old SMTP server IP were located. Deleted the reference, restarted exim and bingo! This is the link where i found the info : techhelpblog.com/2010/08/10/… –  Chris Bull Sep 12 '12 at 7:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.