Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with git, when I run yum upgrade on a centos5 server.

yum upgrade

output:

Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
---> Package perl-Git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(SVN::Ra) for package: perl-Git
--> Processing Dependency: perl(SVN::Delta) for package: perl-Git
--> Processing Dependency: perl(SVN::Client) for package: perl-Git
--> Processing Dependency: perl(YAML::Any) for package: perl-Git
--> Processing Dependency: perl(SVN::Core) for package: perl-Git
--> Running transaction check
---> Package perl-Git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(YAML::Any) for package: perl-Git
---> Package subversion-perl.x86_64 0:1.6.11-10.el5_8 set to be updated
--> Processing Dependency: subversion = 1.6.11-10.el5_8 for package: subversion-perl
--> Processing Dependency: libsvn_wc-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_fs-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_diff-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_subr-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_delta-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_repos-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_ra-1.so.0()(64bit) for package: subversion-perl
--> Processing Dependency: libsvn_client-1.so.0()(64bit) for package: subversion-perl
--> Running transaction check
---> Package perl-Git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(YAML::Any) for package: perl-Git
---> Package subversion.x86_64 0:1.6.11-10.el5_8 set to be updated
--> Finished Dependency Resolution
perl-Git-1.7.11.3-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(YAML::Any) is needed by package perl-Git-1.7.11.3-1.el5.rf.x86_64 (rpmforge)
Error: Missing Dependency: perl(YAML::Any) is needed by package perl-Git-1.7.11.3-1.el5.rf.x86_64 (rpmforge)

When I try yum info perl-YAML, it says, that perl-YAML is installed.

Name       : perl-YAML
Arch       : noarch
Version    : 0.66
Release    : 2.el5.art
Size       : 171 k
Repo       : installed

Whats the problem here?

Thanks flo

share|improve this question
    
Try running cpan -i YAML::Any and see if that helps –  Logic Wreck Sep 10 '12 at 13:41
    
You are installing Git from rpmforge and it may require newer YAML. Try to install newest YAML from CPAN as Logic Wreck recommends. –  Serhiy Sep 10 '12 at 14:14
    
I ran cpan -i YAML:Any, but I get this error also with the newest YAML files. –  sbo Sep 10 '12 at 15:35
    
I'd also encountered this problem. Maybe it's related to other packages/repos installed on the system? –  Xuni Sep 12 '12 at 23:33

1 Answer 1

up vote 0 down vote accepted

I added this one:

http://pkgs.repoforge.org/perl-YAML/perl-YAML-0.72-1.el5.rf.noarch.rpm

which worked for me:

# yum install git
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl-Git = 1.7.11.3-1.el5.rf for package: git
--> Processing Dependency: perl(Git) for package: git
--> Running transaction check
---> Package perl-Git.x86_64 0:1.7.11.3-1.el5.rf set to be updated
--> Processing Dependency: perl(YAML::Any) for package: perl-Git
--> Running transaction check
---> Package perl-YAML.noarch 0:0.72-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch         Version                   Repository         Size
================================================================================
Installing:
 git             x86_64       1.7.11.3-1.el5.rf         third-party       8.2 M
Installing for dependencies:
 perl-Git        x86_64       1.7.11.3-1.el5.rf         third-party        56 k
 perl-YAML       noarch       0.72-1.el5.rf             third-party        84 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade       0 Package(s)

Total download size: 8.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): perl-Git-1.7.11.3-1.el5.rf.x86_64.rpm             |  56 kB     00:00
(2/3): perl-YAML-0.72-1.el5.rf.noarch.rpm                |  84 kB     00:00
(3/3): git-1.7.11.3-1.el5.rf.x86_64.rpm                  | 8.2 MB     00:00
--------------------------------------------------------------------------------
Total                                            38 MB/s | 8.3 MB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-YAML                                                1/3
  Installing     : perl-Git                                                 2/3
  Installing     : git                                                      3/3

Installed:
  git.x86_64 0:1.7.11.3-1.el5.rf

Dependency Installed:
  perl-Git.x86_64 0:1.7.11.3-1.el5.rf      perl-YAML.noarch 0:0.72-1.el5.rf

Complete!
share|improve this answer
1  
it worked! many thanks! –  sbo Sep 18 '12 at 14:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.