Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Wordpress creates the .htaccess file with 600 file permissions (when permalinks are configured, etc.). I had to give it 655 before SuPHP would allow the homepage to load. I thought any files should be read as the user with SuPHP so I'm a bit puzzled here. I'm trying to replicate a shared hosting environment so non-developers and setup CMS'es without difficulty so this is a showstopper for me. Thanks for any help!

share|improve this question

1 Answer 1

You need to chmod .htaccess to 755 in order for it to work, otherwise you will still experience this issue. If you need to do that automatically for files created by apache, please check the next link:
http://stackoverflow.com/questions/428416/setting-the-umask-of-the-apache-user

share|improve this answer
    
Obviously asking a non-dev to chmod their files won't help me. I've read a bit about masks. Can I configure one so that files created by the webserver are given 755 permissions by default? –  jmotes Sep 10 '12 at 16:08
    
I've added a comment. Please check if that helps. –  Logic Wreck Sep 10 '12 at 16:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.