Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to establish trunk between Cisco router 1812 and Catalyst 2960 switch. What I would like to have is that router gets ip address on his fe0 interface and on fe2 provides trunk with 3 VLANs with DHCP server all NAT-ed to fe0.

Here is my shortened current config for with vlan: VLAN 20

ROUTER

! DHCP pool for VLAN-20 
ip dhcp pool vlan20
   network 192.168.20.0 255.255.255.0
   domain-name emergency.lu
   default-router 192.168.20.254
   dns-server 192.168.210.254
!
! this interface provides internet access
interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
! trunk to catalyst switch
interface FastEthernet2
 switchport mode trunk
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly
!
! my first VLAN
interface Vlan20
 ip address 192.168.20.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip nat inside source list 20 interface FastEthernet0 overload
!
access-list 20 permit 192.168.20.0 0.0.0.255
!
route-map NAT_ROUTE permit 10
 match ip address 20
 match interface Vlan20

SWITCH

! notebook connected to this port
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
!
! trunk to cisco router
interface GigabitEthernet0/2
 switchport mode trunk
!
interface Vlan20
 ip address 192.168.20.253 255.255.255.0
!

I thought that when I connect my notebook on port 18 of catalyst I would get Ip address from DHCP on router, but it does not happen.

Also, I cannot ping switch from router and vice-versa. I believe that trunk is not established. What am I missing?

Additional info on request

Router

Router#show vlans

No Virtual LANs configured.

Router#vlan database
Router(vlan)#show
  VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500
    Translational Bridged VLAN: 1002
    Translational Bridged VLAN: 1003

  VLAN ISL Id: 20
    Name: VLAN0020
    Media Type: Ethernet
    VLAN 802.10 Id: 100020
    State: Operational
    MTU: 1500

  VLAN ISL Id: 800
    Name: IOMR
    Media Type: Ethernet
    VLAN 802.10 Id: 100800
    State: Operational
    MTU: 1500
  ...

Swich

Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/19, Fa0/21, Fa0/22
                                                Fa0/23, Gi0/1
2    v2                               active
3    v3                               active
4    v4                               active
5    v5                               active
6    normal                           active    Fa0/20
20   VLAN0020                         active    Fa0/18
100  VLAN0100                         active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
6    enet  100006     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
share|improve this question
1  
can you post the output of "show vlan" on both devices? Did you go into the vlan database and set state to active on vlan 20? –  resmon6 Sep 10 '12 at 17:14
    
Yes, that seems to be the problem. After I enabled vlan20 on router I got IP address. I will now add more VLANS to confirm that it is still working. –  Marko Sep 10 '12 at 17:25
    
New VLAN added and everything works fine. Thanks resmon6! –  Marko Sep 10 '12 at 17:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.