Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Pidgin is telling me my XMPP account was disconnected; the error message is "Host Unknown". What specifically does this indicate? Can it not find the server it's supposed to connect to (one in my office)?

I can ping the server in the "Domain" account setting (under Basic) without a problem, and I even tried specifying an IP address in the "Connect server" account setting (under Advanced) without success.

share|improve this question

closed as off topic by mfinni, rnxrx, Michael Hampton, Ward, Scott Pack Sep 24 '12 at 1:14

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 2 down vote accepted

Check to ensure the SSL certificate used on the server matches the domain setting on the account.

share|improve this answer
I already did. I can ping the name of the domain specified in the account settings, as well as the name of the server it refers to, without a problem. – Mr. Jefferson Sep 10 '12 at 19:21
Is your client the only one having an issue? Is there another user with the same problem? – Fergus Sep 10 '12 at 19:24
It's the same issue throughout the office with Pidgin. I tried iChat from a Mac and it said the password was wrong, but the logs on the XMPP server don't show any connection attempts. And I know the password was right. – Mr. Jefferson Sep 10 '12 at 19:33
I have Wireshark, and I don't know why I didn't think to check it before. Running it while launching Pidgin shows it querying DNS for the account's domain, getting the proper response, and communicating with the server. After a little bit of handshaking, the server replies with the error. I see "service requested for unknown domain" in the text. – Mr. Jefferson Sep 10 '12 at 20:00
Would you happen to have more than one IP addresses on the server interface? – Fergus Sep 10 '12 at 20:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.