Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We just set up a new user at our office and she is getting some weird NDN errors that are consistently inconsistent. When she tries to email some recipients it immediately bounces back a NDN error. These recipients are external to our domain and can be emailed from other users Outlook 2010 clients without issue. Unfortunately the error itself is rather vague and I've pasted it below (some portions redacted for privacy).

Your message did not reach some or all of the intended recipients.

 Subject: test
 Sent:    9/7/2012 4:44 PM

The following recipient(s) cannot be reached:

 'xxxxxxxxxx@xxxxxxx.com' on 9/7/2012 4:44 PM
       None of your e-mail accounts could send to this recipient.

After scouring technet articles I really couldn't find anything of value that will help answer this issue. Any insight would be greatly appreciated.

share|improve this question

1 Answer 1

This usually happens when something bad happens with Outlook's auto-address resolution in your Outlook client. Although the name displays nicely on the screen, it's actually interpreted as having a protocol identifier on the email address (Exchange can send via SMTP or x400) that you don't have a send connector for.

We've fixed this on our network by just clearing the address cache, which can be done by one of two methods:

1. Delete the .nk2 file

Delete \users\[username]\appdata\roaming\microsoft\outlook\Outlook.nk2

2. Clear from Outlook

Or, in Outlook 20120, go to File > Options > Mail > Empty Auto-Complete List

share|improve this answer
    
This is most likely a problem. Its a PITA! Especially when you change Exchange servers and it throws the nickname file all to hell. This is usually because Outlook stores the exchange e-mail address format instead of a normal SMTP address for most users. –  Brent Pabst Sep 10 '12 at 22:19
    
@BrentPabst - yes, we've had that issue with migrating from distinct exchange servers before. You also can't even reply to old messages either. But live and learn... –  Mark Henderson Sep 10 '12 at 22:27
1  
Just to pipe in my two cents: The issue you're describing is due to Outlook's use of the LegacyExchangeDN attribute value to send/reply to Exchange users. This can be mitigated by adding the old LegacyExchangeDN attribute value as an X500 address for each recipient who has been migrated. –  joeqwerty Sep 10 '12 at 23:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.