Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I have an Ubuntu Linux box machine for my website. (not ran locally at home, it is a public linux box). But for some strange reason I can only send Email from my home machine to this box in outlook. If I am on a different IP/Carrier I recieve a connection refused when I telnet.

OUTSIDE House

$ telnet allocatethis.com 25
Trying 64.34.218.41...
telnet: Unable to connect to remote host: Connection refused

Inside House

$ telnet allocatethis.com 25
Trying 64.34.218.41...
Connected to www.AllocateThis.com.
Escape character is '^]'.
220 ALLOCATETHIS-L101 ESMTP Postfix powered by Easy Hosting Control Panel (ehcp) on Ubuntu, www.ehcp.net

I don't see the error when looking mail.log either Below is my main.cf I am fairly new to postfix and would like to get this resolved.

Thanks!!

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name powered by Easy Hosting Control Panel (ehcp) on
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = ALLOCATETHIS-L101
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailnamepostfix/cacert.pem
mydestination = localhost, 64.34.218.41 localhost.allocatethis.com
relayhost =
relay_domains = allocatethis.coma 3600s
mynetworks = 127.0.0.0/8, 192.168.0.0/16, 172.16.0.0/16, 10.0.0.0/8,  64.34.218.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,check_client_access hash:/var/lib/pop-before-smtp/hosts,reject_unauth_destinationsmtp_use_tls = yes
smtpd_tls_auth_only = no
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
debug_peer_list =
sender_canonical_maps =
debug_peer_level = 1
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $cano$inet_protocols = all
smtpd_sasl_local_domain =
share|improve this question
1  
You need to check your firewall settings. –  Logic Wreck Sep 11 '12 at 16:49
    
I have, I have done this by disabling all firewall settings, and doing mobile check from phone, and tablets, gone to several friends houses in which we have disabled the firewall. –  Darxval Sep 11 '12 at 16:58
add comment

2 Answers

up vote 1 down vote accepted

ISPs tend to block outbound connections to port 25/tcp in order to prevent botnet spam. Enable submission (port 587/tcp, must require authentication) in /etc/postfix/master.cf and restart Postfix. Configure your mail client to submit mail via allocatethis.com:587.

share|improve this answer
add comment

The problem is related to your friends ISP.

telnet on port 25 works here.

# telnet allocatethis.com 25
Trying 64.34.218.41...
Connected to allocatethis.com.
Escape character is '^]'.
220 ALLOCATETHIS-L101 ESMTP Postfix powered by Easy Hosting Control Panel (ehcp) on Ubuntu, www.ehcp.net
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.