Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some old RHEL4 servers that until recently I was able to connect to remotely with Exceed (remote desktop using XDMCP) from my windowsXP PC. My PC is connected to our network by wired LAN. Recently it seems something has changed in our network. I can still connect to all the old Solaris and HPUX servers with Exceed, but for some reason I can no longer connect to the RHEL4 servers. I assume this is some kind of "security" feature turned on in our network. Does anyone know what this might be, and how I can tell IT to re-enable it?

Update: A colleague has found that he can connect (very slowly) to these RHEL4 boxes with XDMCP if he is using our VPN from home, but when he is in the office using wired LAN he cannot connect to them. So it seems that there is some kind of firewall or ???, part of our wired LAN network, that is blocking XDMCP traffic from RHEL4.

share|improve this question
    
Sounds like X11Forwarding is set to no in /etc/ssh/sshd_config. –  ansi_lumen Sep 11 '12 at 18:49
    
X11Forwarding is set to yes on the RHEL box. –  joshxdr Sep 11 '12 at 20:00
add comment

3 Answers 3

I've got this bookmark that helped me a lot, when I once set up XDMCP logins.

share|improve this answer
    
I have followed all of the recommendation on that page. Further, nothing in the XDM settings was changed in the last two weeks, so it is hard to explain why XDMCP stopped working. I suspect that some kind of network traffic is being blocked that is particular to Linux XDMCP. –  joshxdr Sep 11 '12 at 20:59
add comment

I don't think there is much we can do to help. You don't appear to have administrative privileges to "fix" the "problem". You need to find who made the recent changes to your network and work with them to reconfigure the network so you can have the access you need.

share|improve this answer
    
My IT is telling me that nothing was changed and there is nothing they can do. I need some more information so I can tell them where to look for the cause of the problem. –  joshxdr Sep 12 '12 at 20:46
add comment
up vote -1 down vote accepted

It seems that I need to use XDMCP over ssh. This is what I did:

(on my Windows PC)

Create a PuTTY session with X11 forwarding ON, display :0

Configure Exceed as multiple windows, passive communication, display 0

Start Exceed

Start Putty with X11 forwarding

Type nedit& (or whatever xwindows app you need)

share|improve this answer
    
The solution doesn't involve XDMCP. –  Iain Sep 15 '12 at 12:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.