Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I try to start my Nginx and I get the below error after the below command:

sudo /etc/init.d/nginx start

Starting nginx: start-stop-daemon: unable to start /usr/local/nginx (Permission denied)

My config file is:

user www-data www-data;
worker_processes  1;

events {
    worker_connections  2048;
}

http {
    include       mime.types;
    default_type  application/octet-stream;

    access_log  off

    sendfile        on;
    tcp_nopush      on;
    tcp_nodelay     off;
    keepalive_timeout  10;

    gzip  on;
    gzip_comp_level 2;
    gzip_proxied any;
    gzip_types      text/plain text/css application/x-javascript text/xml application/xml application/xml+rss text/javascript;


    server {
        listen       80;
        server_name  localhost;

        location / {
            root   html;
            index  index.html index.htm;
        }

        error_page   500 502 503 504  /50x.html;
        location = /50x.html {
            root   html;
        }

    }
        include /usr/local/nginx/sites-enabled/*;
    }
share|improve this question
    
What process did you follow to install nginx? –  Shane Madden Sep 12 '12 at 5:54
    
wget nginx.org/download/nginx-1.2.3.tar.gz tar xvfz nginx-1.2.3.tar.gz cd nginx-1.2.3 ./configure make sudo make install –  Ido B Sep 12 '12 at 5:59
    
Your system hasn't got a package manager? Do you use LFS? –  VBart Sep 12 '12 at 20:29

1 Answer 1

try:

chmod +x /usr/local/nginx
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.