Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working with MATLAB on a remote computer logging in via ssh -X remotepc and running matlab like matlab &.

When I start a long-running process and leave the computer, it seems to suspend the process (after like 30mins being away) such that there is nearly no progress over night.

As soon as I come back and wake up the client, the remote process continues with the calculation. I can see this from the load-average values (uptime)

Why is that and how can I change this behaviour?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

There are two options that look helpful in man ssh_config:

TCPKeepAlive – this should be yes on default, if it isn't on your machine try ssh -X -o TCPKeepAlive=yes remotepc.

ServerAliveInterval – use it like ssh -X -o ServerAliveInterval=30 remotepc to make ssh send a "keepalive" packet every 30 seconds.

Apart from man ssh_config I found this reference.

share|improve this answer
    
Ok, I will try it out –  Philipp F Sep 25 '12 at 7:10
add comment

Your description suggests to me that the remote machine is hibernating/suspending after a period of being idle (with respect to user input). You should check the power settings on that machine and adjust them to either disable hibernation/suspension or at least lengthen the idle time.

share|improve this answer
    
Hi. I'm pretty sure it doesn't, since it's a linux server that runs 24/7. I'm not the only one who uses it. –  Philipp F Sep 13 '12 at 8:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.