Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an EC2 Micro running Ubuntu 12.04. I have assigned it an EIP (23.21.213.236) and I am pointing my domain name A records to this IP.

The domain I am trying to access with is utoolsandfixings.co.uk, this should show a page saying "Server Found".

I have tried restarting NGINX after I made all my amendments.

I have installed NGINX on the server and setup a VHost, set up a symlink etc. The VHOST is as follows:

server {
    listen 80; ## listen for ipv4
    server_name utoolsandfixings.co.uk; ## change this to your own domain name
    # I find it really useful for each domain & subdomain to have its own error and access log
    error_log /var/log/nginx/utoolsandfixings.co.uk.error.log;
    access_log /var/log/nginx/utoolsandfixings.co.uk.access.log;
    location / {
            # Change this to the folder where you want to store your website
            root /var/www/utoolsandfixings.co.uk/;
            index index.html index.htm index.php;
    }
    # redirect server error pages to the static page /50x.html
    #
    error_page 500 502 503 504 /50x.html;
    location = /50x.html {
            root /var/www/nginx-default;
    }
    # We haven't setup FastCGI yet, but lets configure this now anyways
    #
    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
    location ~ \.php$ {
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index index.php;
            # again, change the directory here to your website's root directory make sure to leave $fastcgi_script_name; on the end!
            fastcgi_param SCRIPT_FILENAME /home/meltingice_net/public_html$fastcgi_script_name;
            include /etc/nginx/fastcgi_params;
    }

}

Also my nginx.conf

user www-data;
worker_processes 4;
error_log /var/log/nginx/error.log;
pid /var/run/nginx.pid;

events {
    worker_connections 1024;
    # multi_accept on;
}
http {
    include /etc/nginx/mime.types;
    access_log /var/log/nginx/access.log;
    sendfile on;
    #tcp_nopush on; keepalive_timeout 0;
    keepalive_timeout 2;
    tcp_nodelay on;
    gzip on;
    gzip_disable msie6;
    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}

Any help at all would be much appreciated.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Is NGINX running (started) on the instance? /etc/init.d/nginx status

Suspect that this is a firewalling issue, have you assigned a security group to the instance that allows HTTP? There is a reasonable guide here.

Additionally, have you checked there isn't a local firewall on the instance dropping incoming traffic? sudo iptables --list

share|improve this answer
    
EDIT: this has been sorted. Excellent! That seems to have fixed my no response problem (HTTP security groups). I'm now getting a No input file specified error. Is that something wrong with my configuration? –  GaryDevenay Sep 12 '12 at 12:39
    
@GaryDevenay suggest you make a new question about the other problem, it'll give you a better chance of getting an answer, more quickly too. –  James Yale Sep 13 '12 at 9:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.