Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just updated PHP and MySQl on my VPS with the current Versions from Atomic Repo.

Everything worked out fine so far.

From console I get the new PHP 5.3:

[root@server phpMyAdmin]# php -v

PHP 5.3.16 (cli) (built: Aug 20 2012 11:18:05) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies with the ionCube PHP Loader v4.0.5, Copyright (c) 2002-2011, by ionCube Ltd.

But through Apache I still get the old version (5.1.6).

The server is running some old version of crappy Plesk Panel. That gives me the option to choose between Apache Modul, fCGI and CGI-BIN.

Any hints, how to update apache, so it will use the new PHP Version?

EDIT: I just needed to restart httpd (/etc/init.d/httpd restart)

share|improve this question
    
It would be nice if you'd accept quanta's answer, seeing how that was the solution. –  HopelessN00b Oct 9 '12 at 3:42

1 Answer 1

Have you tried to restart Apache?

sudo /etc/init.d/httpd restart
share|improve this answer
    
What an embarrassment! Thank you very much. I thought, yum has done that for me. –  mblaettermann Sep 12 '12 at 14:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.