Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a medium sized Drupal 7 website on my miniserver but I keep getting a 500 error message. This is what I found in Apache's error log:

[Wed Sep 12 15:02:04 2012] [notice] SSL FIPS mode disabled
[Wed Sep 12 15:02:04 2012] [warn] No JkShmFile defined in httpd.conf. Using default /usr/local/apache/logs/jk-runtime-status
[Wed Sep 12 15:02:04 2012] [notice] Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.35 configured -- resuming normal operations
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] /usr/bin/php: error while loading shared libraries: libkrb5support.so.0: failed to map segment from shared object: Cannot allocate memory
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] Premature end of script headers: index.php
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] /usr/bin/php: error while loading shared libraries: libkrb5support.so.0: failed to map segment from shared object: Cannot allocate memory
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] Premature end of script headers: index.php
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] File does not exist: /home/brighton/public_html/favicon.ico
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] /usr/bin/php: error while loading shared libraries: libkrb5support.so.0: failed to map segment from shared object: Cannot allocate memory
[Wed Sep 12 15:02:07 2012] [error] [client 89.16.136.28] Premature end of script headers: index.php

I contacted support and they just told me I should just upgrade my package (right not I have a 512Mb account), but I am not sure if I'm buying it... even if I'm trying to access a file which only contains phpinfo(); I still get the 500.

Any help would be much appreciated, and if there's need of any other information please let me know and I'll update the question. I compiled apache with tomcat because I intend to use Solr... not sure if this is relevant or not.

share|improve this question
    
Please show us your top? –  quanta Sep 12 '12 at 14:41
    
@quanta here's the screenshot: i.imgur.com/7GE0V.png –  la_f0ka Sep 12 '12 at 14:46
    
Can you also add the output from free -m? It looks like you've just run out of memory and have no VM so once the RAM is used up things that need memory just won't work anymore. –  uesp Sep 12 '12 at 16:14
    
@uesp here's that output: i.imgur.com/73HYQ.png –  la_f0ka Sep 12 '12 at 16:34
    
Its probably not due to low memory then as you have plenty of memory in the "cache" which could be used for applications. –  uesp Sep 12 '12 at 16:54
show 2 more comments

1 Answer

Give some memory limitation in JAVA_OPTS, like the parameter "-Xmx256m". I advise you this solution but in some JDK seems to don't work properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.