Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using IIS Manager to remotely manage another IIS server.

When I'm managing the local server, I can select the "Server Certificates" icon under IIS when I select the local server in the list to the left.

However, when I select the remote server in the list, the icon for "Server Certificates" disappears.

Is there a way to get it to show up?

share|improve this question
Sorry if this is a silly question, but why not just connect to the other IIS server and select the Certificates from there? If nothing else, it would be useful to troubleshoot where the error is (such as if there's a good reason it's not showing up from the remote server, like that one IIS server not having the requisite roles or configurations in place). – HopelessN00b Sep 13 '12 at 5:07
That would be easy if it was possible, but the server is running the server core version of Windows, so no other UI than a command prompt. And installing the full UI is not an option, also, it should be doable remotely somehow :) – GurliGebis Sep 13 '12 at 7:00
Might be time to brush up on your CLI skills so you can check the IIS configs from the actual box in question? :) – HopelessN00b Sep 13 '12 at 7:28
I know my CLI pretty well, I have however not been able to find which powershell cmdlet to call to send a domain certificate request. – GurliGebis Sep 13 '12 at 9:39
up vote 2 down vote accepted

This is not currently possible in IIS 7.x becuase the Server Certificates functionality depends on the certificate store. Since there is no way to remotely access the certificate store via the IIS Management application the option is not made available when working on a remote server.

share|improve this answer
Thanks, that explains why it does not work. – GurliGebis Dec 1 '12 at 23:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.