Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

To preface, this is my first experience with 10GbE networking and I have encountered an issue which my research does not seem to locate a solution for...

I have two servers (older DL580G5 and DL380G5), each with a HP NC522SFP, 10GbE dual sfp+ port adapter. I have purchased copper "passive" direct connect adapter cables (that look like twinax), which seem to work well when I connect them to the sfp+ ports on my Dell 5524 switch. However, if I directly connect the two servers with the same cable, the link doesn't come up. I am running Window Server 2012 Standard on each server. My intention is to use one of these servers as a homebrew SAN and I would like to enable multiple 10GbE paths for iSCSI traffic.

My question(s):

Can I connect the two adapters to each other, such as I would with previous, less speedy generations of Ethernet?

If I can, do I require a crossover cable, or is there some type of other sfp+ cable solution to do this? My 10GbE sfp+ switch ports are premium, but server-to-server connections are doable in small numbers for me, and I would really like the multiple paths this would give me.

Is there a simple solution to this issue?

share|improve this question
add comment

3 Answers

Automatic MDI/MDI-X is required part of Ethernet standard since 1Gbps era.

I'd guess that it is just disabled (either BIOS or driver level) in your case.

share|improve this answer
add comment

The "crossover" is already built in to these cables. When working with cables like these you don't have a concept of a DTE side and DCE side as you do with ethernet cables. On a typical ethernet cable the DTE(terminal) side will have transmit on pins 1 and 2, with receive on pins 3 and 6. The DCE(switch) side or the other end of that cable will be flipped with transmit on 3 and 6 and receive on 1 and 2. These direct attach cables are built with the transmit of one side built already connected to the receive of the other.

share|improve this answer
add comment

There are two types of DAC cables, Active and Passive. You might have the wrong cable for your SPF+ ports.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.