Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've connected to my ftp server from my local linux terminal.

As far as I understand I've been using the ! to navigate through local files (i.e !ls vs ls)

I can't seem to cd .. to my home folder, I'm trying to access /home/web but the farthest i can go is to /home/my_user

Can someone explain why and what I'd need to do to change this?

Thanks!

share|improve this question
2  
It sounds like your ftp server is setup with CHROOT. If you gave us some useful details like what FTP server you are using, maybe a config fragement, and or other details, we might actually be able to provide some useful help. –  Zoredache Sep 13 '12 at 0:35
    
I think this is more of a linux question than a server question.. I might move this to a different stack –  d-_-b Sep 13 '12 at 0:39
    
@iight Or an FTP server/daemon question, not specific to Linux... –  HopelessN00b Sep 13 '12 at 0:53
    
It is totally on topic. –  Falcon Momot Oct 21 '12 at 9:31

1 Answer 1

This is normal behaviour. Most of the FTP Server lock the user to their respective home directory to prevent access to other filesystem files. This is called "chroot", because you change the root directory of the this process.

In vsftp for example you can disable it by editing the configuration file /etc/vsftpd/vsftpd.conf and change this value to no:

chroot_local_user=no

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.