Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using uberSVN on Ubuntu server. Now, I can't checkout, commit source from Subversion Server (, port subversion)

I tried to start httpd by command line as:

sudo /opt/ubersvn/bin/httpdserverctl start

, but I get error:

httpd: Could not reliably determine the server's fully qualified domain name, using for ServerName
httpd (pid 895) already running

I tried run this command as follow:

cd /opt/ubersvn/bin
 sudo ./ubersvncontrol start

then get errors:

Starting SysV Tomcat
Using CATALINA_BASE:   /opt/ubersvn/tomcat
Using CATALINA_HOME:   /opt/ubersvn/tomcat
Using CATALINA_TMPDIR: /opt/ubersvn/tomcat/temp
Using JRE_HOME:        /opt/ubersvn/jre
Using CLASSPATH:       /opt/ubersvn/tomcat/bin/bootstrap.jar
Using CATALINA_PID:    /opt/ubersvn/data/run/
Existing PID file found during start.
Tomcat appears to still be running with PID 943. Start aborted.

In the Ubersvn website GUI, I tried start Ubersvn server but get error :

enter image description here

How to start Subversion Server ?

share|improve this question
What error message are you getting when you attempt to check out or commit? – Shane Madden Sep 13 '12 at 4:52
hi Shane Madden, I can't connect ubersvn port 9080, then i can't checkout or commit – dakiquang Sep 17 '12 at 2:49

The first line is only the warning. Change the ServerName directive in the Apache configuration file to something like this ServerName :80 to make it go away.

The second line means that...the Apache is already running. How about this:

cd /opt/ubersvn/bin
./ubersvncontrol start
share|improve this answer
hi quanta, i've updated my question with command that you need. Please check it. :) thank – dakiquang Sep 13 '12 at 5:02
Did you see that Tomcat appears to still be running with PID 943. Start aborted.? – quanta Sep 13 '12 at 7:12
I see that, but how to fix it ? – dakiquang Sep 17 '12 at 2:57

You can check the status and start, stop or restart Apache and uberSVN from the 'Status' tab of uberSVN.

What does it say the status is currently?

share|improve this answer
Hi Mand Beckett, I just updated my question above about the state status tab, you can see it. – dakiquang Sep 17 '12 at 2:57
up vote 0 down vote accepted

I have found out the answer for my problem. You just need delete the file /opt/ubersvn/data/run/ and remove all file in log folder of Ubersvn /opt/ubersvn/data/logs/.

Then you could restart the this server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.