Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an application that sends UDP broadcasts to some port, for example 11000 (BROADCAST_APP) and another application that listens the 11000 UDP port(LISTENER_APP). The apps works well on the physical LAN (192.168.1.0/24) when I started the listener on my physical interface

 UDP    192.168.1.16:11000     *:*

and send broadcast from machine 192.168.1.11.

But I want to test them in the virtual network so I run the BROADCAST_APP in the guest WinXp machine and LISTENER_APP in the host Win7 machine on virtual interface:

 UDP    192.168.56.1:11000     *:*

My host machine have virtual adapter with address 192.168.56.1 and guest machine 192.168.56.2. I can ping guest from host and vice versa.

However, my broadcasts from guest not reached the LISTENER_APP. I run the virtual machine in the Oracle VirtualBox.

share|improve this question
1  
And your firewall and networking rules allow UPD traffic between VMs, and on port 11000? ICMP traffic isn't the same as port-specific traffic on a different protocol, and any firewalls, or even routing rules won't [necessarily] treat different traffic the same way. –  HopelessN00b Sep 13 '12 at 8:39
    
I switched off Windows Firewall on host machine and all works now. The location of my virtual adapter is public network and firewall was blocking all incoming connection from public networks only. –  T_12 Sep 13 '12 at 8:49

1 Answer 1

up vote 1 down vote accepted

From the comments, Windows Firewall did it, as it was set to block connections from public networks, which is/was the location of the virtual adapters doing the UDP broadcasts. Turning off the firewall fixed the problem.

By the way, if you haven't done so already, a more secure approach would be to make a rule for the inter-VM communications and/or designate the virtual adapter to be in a more "trusted" network within Windows Firewall and/or your host network's settings.

share|improve this answer
    
I've already applied the rule for incoming connection, but thanks for response anyway. –  T_12 Sep 13 '12 at 9:22
    
@T_12 Yeah, putting (and accepting) the answer in the answer section is etiquette at StackExchange, to make the thread more useful and easy to glean information from for future visitors who mind find it through Google or whatever... so it's more for anyone who comes along later with the same problem than for you. I knew you knew the answer when you posted it in the comments. :) –  HopelessN00b Sep 13 '12 at 9:48
    
of course, you're right, I made that just for "finish the job" –  T_12 Sep 13 '12 at 10:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.