Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have implemented DAOS on a Lotus Domino Server (8.5.3 FP2) as follows:

Lotus Domino Server Document:

  • Store file attachments in DAOS: Enabled
  • Minimum size of object before Domino will store in DAOS: 64000 bytes
  • DAOS base path: E:\DAOS
  • Defer object deletion for: 30 days

Transaction logging is running, and the specific test database has the following advanced properties set:

  • Domino Attachment and Object Service (ticked)
  • Use LZ1 compression for atachments
  • Compress Database Design
  • Compress Data

I have restarted the server. When I run a compact -c, it compacts the database, but does not reduce the size. I have checked the DB in Windows Explorer (60Gb) and the size is the same pre and post. I have checked the directory (E:\DAOS) and it is 35Gb in size.

When I run the command 'Tell DAOSMgr Status tmp\test.nsf', I get the following response. From looking up on the net, I believe ticket count = 0 means that the db is not really DAOS'ed?

Admin Process: Searching Administration Requests database
DAOSMGR: Status tmptest.nsf started
DAOS database status:

Database: E:\Lotus\Domino\Data\tmp\test.nsf
Database state = Synchronized
Last resynchronized: 03/09/2012 02:49:13 PM
Ticket count: 0
DAOSMGR: Status tmp\test.nsf completed

I have run fixup on the database. When I have tried to run the DAOS estimator it has always crashed. This was a problem with larger databases on earlier versions of domino, but not anymore.

Can anyone tell me why the size has not reduced? Am I missing anything?

share|improve this question

I think you have DAOS slightly mixed up. DAOS removes the attachments out of documents and stores them on the server, so if one emails is sent with a large attachment it is not stored in every database, just one file in DAOS.

Here are some links: this is to reduce the number of nlo files.

Also someone on IBM support ask the same question, I would recommend reading it here

share|improve this answer
Thanks - I have looked into it further and have worked out the problem, see below. Thanks for the links, there was some confusion there. I am not looking to reduce the size of the NLO files, but the size of the DB. Looks like there was a db problem which is now resolved. – SydxPages Sep 13 '12 at 22:19
up vote 0 down vote accepted

So - looks like the problem was with the database. I ran a fixup on the db which deleted a corrupt document - this was a test db so will now find out what the corrupt document was.

Now, when I run 'Tell DAOSMgr Status tmp\test.nsf', I get the following response:

DAOSMGR: Status tmp\test.nsf started
DAOS database status:
Database: E:\Lotus\Domino\Data\tmp\test.nsf
Database state = Synchronized
Last resynchronized: 13/09/2012 07:24:33 PM
Ticket count: 106165
DAOSMGR: Status tmp\test.nsf completed

Ticket count no longer 0.

share|improve this answer

There are some important points when you implement DAOS (in my eyes). Some are also mentioned here

1.) You should keep your Backup software in mind, not every supports DAOS. If the software didn´t support DAOS you still CAN restore the mailfile but must then restore each *.nlo file per hand to the DAOS folder. You can find more infos here:

So the most company's enable DAOS on there primary server (from a cluster) and on there 2nd server which act as failover they run the backup (without DAOS enabled).

2.) I would enable DAOS also on the as mentioned here:

3.) Keep in mind that the NLO files are encrypted on default. This might be a problem for the restore on your side.

4.) You should exclude the NLO via antivirus:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.