Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got a server with 2 NIC's.

One is the external interface, that has a public IP.

When only that interface is up, I can ping it fine from our internal network.

When I enable the second interface with the internal IP address on, I cannot ping the external IP anymore from the internal network. I can however ping it from a server on another internet connection.

I have been dealing with this for quite some time, and I really cant figure out why it won't work..

I have rebooted the server numerous times, without effect.

Interface configurations are as follows:

ifcfg-eth0 (External)

DEVICE="eth0"
BOOTPROTO="static"
HWADDR="00:24:81:82:D2:26"
NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="d8c860fb-eab3-410c-a137-b100fa77ca51"
NETMASK="255.255.255.240"
IPADDR="7x.6x.1xx.1xx"

ifcfg-eth2 (Internal)

DEVICE="eth2"
BOOTPROTO="static"
HWADDR="00:23:7D:9C:CA:A7"
NM_CONTROLLED="yes"
ONBOOT="yes"
TYPE="Ethernet"
UUID="d544ec14-80fa-4765-bec4-e616b0b86bb8"
NETMASK="255.255.255.0"
IPADDR="192.168.11.15"

/etc/sysconfig/network

NETWORKING=yes
HOSTNAME=HOSTNAME
GATEWAY=7x.6x.1xx.1xx

Routing table

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
7x.6x.1xx.1xx   *               255.255.255.240 U     0      0        0 eth0
192.168.11.0    *               255.255.255.0   U     0      0        0 eth2
link-local      *               255.255.0.0     U     1002   0        0 eth0
link-local      *               255.255.0.0     U     1004   0        0 eth2
default         ip07x06x1xx1xx. 0.0.0.0         UG    0      0        0 eth0

I am pinging from a computer in the 192.168.11.0 network. There is a hardware firewall between them, but the logs show nothing of interest.

They are connected to the same switch on the 192.168.11.0 network.

share|improve this question
    
You forgot to tell us the IP of the machine you are pinging from and how they are connected. Do you have firewall enabled? –  Khaled Sep 13 '12 at 11:04
    
I have added the details to the question. –  Frederik Nielsen Sep 13 '12 at 11:16
    
@FrederikNielsen WHAT TYPE OF HARDWARE FIREWALL? –  ewwhite Sep 13 '12 at 11:21
    
@ewwhite Astaro ASG 220 –  Frederik Nielsen Sep 13 '12 at 11:23

1 Answer 1

And in general, modify your config to disable the NetworkManager control with: NM_CONTROLLED="no". Also disable the NetworkManager service if it's running...

See if that helps first.

Outside of that, what is the source of your ping? 192.168.11.x?

share|improve this answer
    
Setting NM_CONTROLLED="no" didn't change anything - still doesn't work. The service networkmanager does not exist on my system. I have added some detail to the question about the source, but yes it is from the 192.168.11.0 network. –  Frederik Nielsen Sep 13 '12 at 11:21
    
Do you have any other ideas? –  Frederik Nielsen Sep 19 '12 at 11:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.