Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having the strangest time getting a Thunderbird email client to connect to my Exchange 2003 server.

I got the incoming IMAP account set up no problem, and I can receive mail. However sending mail will not work no matter what SMTP settings I enter. After checking the server, the proper settings should be port 25 with no authentication or connection security, which I have entered. I can ping the hostname of the server from the client machine in question. The Thunderbird error message I get is:

"Sending of message failed. The message could not be sent because the connection to SMTP server -hostname omitted- was lost in the middle of the transaction."

So I went to the server and double checked the settings for Exchange's SMTP stuff. I have it correct. I tried to telnet (on the server) to localhost 25. It appears to connect and then disconnect immediately, no message, no nothing. When I telnet to other ports (POP-110 for example) I get proper connection messages and a stable connection. There are no firewalls on either the client or the server. There's a firewall on the network but LAN->LAN traffic is unrestricted.

I can reproduce the Thunderbird error on a second client, and I can't get any client to be able to telnet in.

EDIT: I'm having the same problem with Zimbra Desktop.

Anyone have any ideas?

share|improve this question
    
Disable the Connection filter on the properties of the SMTP Virtual Server and try both the Thunderbird and Telnet test again. –  joeqwerty Sep 13 '12 at 15:15

1 Answer 1

up vote 0 down vote accepted

In Exchange System Manager, Org/Servers/ServerName/Protocols/SMTP/ Properties on your Virtual Server.

Access tab.... Authentication - Anonymous should be checked

Connection Control - All except...

Relay (key) - Make sure bottom "allow those that authenticate" is checked. I would also, for grins, add the IP of your client to the lest. At least this way you have something to test with.

N

share|improve this answer
    
Thank you! It was the Connection Control that I had missed. For some reason the subnet had been added as a single computer entry (eg. 10.0.0.0 instead of 10.0.0.0 (255.0.0.0)) and 127.0.0.1 wasn't in the list at all. When I deleted the single entry for the subnet and readded it properly as a group of hosts, everything began to work. I'm not sure if adding 127.0.0.1 is actually necessary, but I added it as well. –  speedreeder Sep 14 '12 at 11:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.