Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After some research from our team and trial and errors, we we're not able to make '--disable-dom' dissapear from the phpinfo.

I've tried to reinstall php-xml but I got the following message:

Package php-xml-5.3.3-14.el6_3.x86_64 already installed and latest version
Nothing to do

The server is running on CentOS release 6.3 (Final)

Here's the info under 'dom' section of phpinfo:

DOM/XML               enabled
DOM/XML API Version   20031129
libxml Version        2.7.6
HTML Support          enabled
XPath Support         enabled
XPointer Support      enabled
Schema Support        enabled
RelaxNG Support       enabled

Anything else we should try in order to have the --disable-dom removed from the php configuration?

Thanks.

[EDIT]

Is There an easy way to recompile php on CentOS6 ?

share|improve this question
    
We finally found the problem. It was Chmod permission for the cache folder. It couldn't write, so we chmod 777. Thanks. –  aurevilly Sep 19 '12 at 18:25

1 Answer 1

up vote 1 down vote accepted

Why do you want to? There is absolutely no need for what you're trying to do.

The reason that --disable-dom appears in the phpinfo() is that on Red Hat, PHP and its modules are generally built separately; PHP actually gets built three times (or maybe it's four) during the RPM build process to account for each SAPI. Once the resulting binaries are installed on your system, though, there is no functional difference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.