Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Giving Cherokee a first spin to try it out so bare with me if that's a dumb question.

I've installed it on a CentOS 6.3 VM through EPEL repo.

If i open http://localhost in elinks (sorry no gui) I can see the "Powered by Cherokee" page fine.

I've then launched the cherokee-admin process and open http://localhost:9090 in elinks.

I'm being asked the login and passsword, which I enter, but then nothing happens. It gets stuck loading.

I've tried the ssh tunnel technique to load it in a fancier browser like chrome in case that was the problem but it's the same scenario, I get the popup asking me for the username and password but then the browser gets stuck loading.

On a few occasions, Chrome shows a "504 Gateway Timeout" message but not always. If I refresh when that happens then it gets stuck again.

What am I missing here?

EDIT: If i let chrome running long enough I get this error message:

503 Service Unavailable

------------------------

Cherokee web server 1.2.101 (UNIX), Port 9090

EDIT 2: I've got Python 2.6.6

EDIT 3:

This is the output when I start cherokee-admin -x -b

Cherokee Web Server 1.2.101 (Feb 21 2012): Listening on port ALL:9090, TLS
disabled, IPv6 enabled, using epoll, 4096 fds system limit, max. 2041
connections, single thread

Login:
  User:              admin
  One-time Password: 2nEKQfD3RqLbKJ5a

Web Interface:
  URL:               http://localhost:9090/

When I open up the admin in a browser the cherokee-admin displays this:

DEBUG: SIGUSR1 invokes the console..
       SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=3570 Port=4000
share|improve this question

1 Answer 1

I'm not entirely sure why (as in, I really don't know) but if I run cherokee-admin with -t switch then it loads fine.

The -t switch is described as

-t, --internal-unix
By default, cherokee-admin uses TCP for internal communications. 
This parameter specifies that a Unix domain socket should be used instead. 
The default behavior is the safest one, so this parameter should rarely by used.

So that fixes the problem I guess.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.