Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell Server with 2 onboard bce(4) NICs. Those two are trunked together using LACP to lagg0 on a EX2200 Juniper Switch. Over lagg0 i have 2 vlans.

Everything works fine when i only have one vlan configured, as soon as i configure the second, i start having sshd broken pipe issues for connections going to the server.

Best example, when i ssh into that server, it works for like 30 seconds, after that it will freeze with a broken pipe.

As soon as i remove the 2nd vlan (or at least take the IP Address off it), it will work fine again.

I might also add that this only breaks on routed traffic, if the traffic is coming from the same subnet as the vlan, it's fine.

[root@fbsd9] ~ # ifconfig
bce0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
    ether 00:1a:a0:05:c5:da
    inet6 fe80::21a:a0ff:fe05:c5da%bce0 prefixlen 64 scopeid 0x1 
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
bce1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
    ether 00:1a:a0:05:c5:da
    inet6 fe80::21a:a0ff:fe05:c5d8%bce1 prefixlen 64 scopeid 0x2 
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7 
    inet 127.0.0.1 netmask 0xff000000 
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=c01bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
    ether 00:1a:a0:05:c5:da
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    laggproto lacp
    laggport: bce1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
    laggport: bce0 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
vlan4094: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=103<RXCSUM,TXCSUM,TSO4>
    ether 00:1a:a0:05:c5:da
    inet6 fe80::21a:a0ff:fe05:c5da%vlan4094 prefixlen 64 scopeid 0x9 
    inet 172.16.1.197 netmask 0xffffffc0 broadcast 172.16.1.255
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    vlan: 4094 parent interface: lagg0
vlan4093: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=103<RXCSUM,TXCSUM,TSO4>
    ether 00:1a:a0:05:c5:da
    inet6 fe80::21a:a0ff:fe05:c5da%vlan4093 prefixlen 64 scopeid 0xa 
    inet 172.16.2.19 netmask 0xffffff00 broadcast 172.16.2.255
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    vlan: 4093 parent interface: lagg0
share|improve this question

1 Answer 1

I figured it out myself,

the issue was that my junos router infront of the EX2200 had issues with assigning the MAC-addr of the lagg0 (and therefore the vlan*) to the right VLAN. I'll simply use a dedicated ethernet card to do routed services like ssh and stuff.

this way customers can connect to the server from within their vlans while i still have outbound/routed connectivity on the mgmt interface.

best regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.