Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS virtual machine running remotely, accessible via VPN. It was set up to sync time from two servers on the same network. The time set is approximately right, but seems to be drifting off. I am concerned by the mention of the date 2036 in output below, should I be?

/usr/sbin/ntpq -pcrv
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 10.245.8.100    10.249.8.100     2 u   24   64  377    1.185  12124.8  29.489
 10.249.8.100    .RMOT.          16 u    - 1024    0    0.000    0.000   0.000
assID=0 status=c011 sync_alarm, sync_unspec, 1 event, event_restart,
version="ntpd 4.2.2p1@1.1570-o Fri Nov 18 13:21:21 UTC 2011 (1)",
processor="x86_64", system="Linux/2.6.18-308.el5", leap=11, stratum=16,
precision=-20, rootdelay=0.000, rootdispersion=56.655, peer=0,
refid=INIT, reftime=00000000.00000000  Thu, Feb  7 2036  6:28:16.000,
poll=6, clock=d3fd6d1a.a01aab1b  Fri, Sep 14 2012  9:45:14.625, state=1,
offset=0.000, frequency=0.000, jitter=0.001, noise=0.001,
stability=0.000, tai=0

[edit] as per suggestions below, further information...

sudo /usr/sbin/ntpdate 10.245.8.100
14 Sep 13:02:02 ntpdate[7766]: step time server 10.245.8.100 offset 12.212849 sec

and ntp.conf

restrict 127.0.0.1 
restrict -6 ::1

server 10.245.8.100
server 10.249.8.100

driftfile /var/lib/ntp/drift

keys /etc/ntp/keys

server 10.245.8.100
restrict 10.245.8.100
server 10.249.8.100
restrict 10.249.8.100
share|improve this question
    
I compare with output of my ntp. 10.249.8.100 - dont work. 10.245.8.100 - give out date "Fri, Sep 14 2012 9:45:14.625". What is your current clock ($ date)? –  mmv-ru Sep 14 '12 at 13:52
    
I think this is probably because that ip address is for the local network. $date> Fri Sep 14 15:49:34 BST 2012. (this seems about right for now). –  niciliketo Sep 14 '12 at 14:49
    
The conf looks right, but 10.249.8.100 can't be reached. And the offset for 10.245.8.100 is way too high. Try again without the restrict options. –  Martin Schröder Sep 15 '12 at 11:45
    
Thanks, removing the restrict options seems to have helped. it still gets a few seconds out of sync before correcting itself, but at least now it doesnt carry on getting worse. –  niciliketo Sep 19 '12 at 14:35
add comment

1 Answer 1

Look weird.

  • "stratum=16" say it not synced to time source.
  • reach 377 - ntp server reachable.
  • offset 12124.8 - big out of sync

Attempt do "ntpdate 10.245.8.100" for quick sync clock at beginning.

Possible big adjustment disabled in configuration as measure against misconfiguration? Show your ntpd.conf

Add as first, restrict rule to allow synchronisation

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery

# Permit all access over the loopback interface.  This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.0 mask 255.0.0.0
restrict -6 ::1
share|improve this answer
    
I have added the suggested details above, ntpdate command didnt give any errors, but I am guessing there is a problem with my conf file somehow? –  niciliketo Sep 14 '12 at 12:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.