Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My problem is simple. I did some changes on a homepage this morning (add some sentence) and it did not appear in my browser. I cleared symfony cache, nginx cache, apc cache, restart apache, restart nginx and... nothing.

Then I tried to access it from my smartphone. Still nothing. But my coworker tried and it worked. (we have both different ISP)

So I suggested it was ISP caching problem. Because I tried to wget it from a production server and it worked.

Then I tried something else: I accessed my homepage by www.mydomain.com but I modified the header with Apache IP address instead of Nginx IP address and it worked.

So it looks like it's a Nginx-ISP problem but I can't figure out what's wrong...

Any help would be very appreciated !

Here is my NGINX configuration file:

server {
    listen   80; ## listen for ipv4

    server_name  www.mydomain.com;

    access_log  /var/log/nginx/nginx1.access.log;
    error_log   /var/log/nginx/nginx1.error.log;


    location / {
            proxy_pass http://apache;
    }

    location ~* ^.+.(swf|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js|woff)$ {
             proxy_cache_valid 2d;
             proxy_pass http://apache;
             proxy_cache staticfilescache;
    }

)
share|improve this question
    
Did you clear your browser cache? –  Michael Hampton Sep 14 '12 at 13:35
    
Yes, of course :) –  YoH Sep 14 '12 at 14:17
    
Actual request and response headers are needed, and more info about ISP's cache. F.e. is it a transparent one? –  sendmoreinfo Dec 27 '12 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.