Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 nameservers running Windows Server 2008. On these servers we have routeable and private/non-routeable ( 10. _ . _ ._ ) IPs.

The problem is that a query for the nameserver's network name returns non-routeable ips. These IPs need to be on the computer but shouldn't be returned by DNS. I have selected the option to not automatically register these IPs in DNS.

I have also deleted these non-routeable IPs manually in DNS.

My problem is that everytime I delete these IPs, they are created again in DNS. I have turned off dynamic updates on the zone on the server side and set the interface to not register in DNS on the client site! But the IPs still show up.

Also, I have tried fixing the nameserver ( NS ) records on the zone to be the 2 IPs we need them to be. But sure enough, the non-routeable IPs get added as NS records repeatedly after being deleted.

How can I get back crontrol of my DNS? How can I get Windows to stop dynamically adding IPs I am deleting?

share|improve this question
add comment

3 Answers

Found the issue.

I forgot to choose the interfaces that DNS listens to on the new server. By default the DNS server listens to all network interfaces. Because of this, it seems to register all interfaces that are enabled.

Right-click on the server in the DNS management snap-in, and choose properties. You can then select the interfaces you would like.

share|improve this answer
add comment

Are you running active directory? If you do, please check if you have any abandoned computer records.

share|improve this answer
    
Thanks for the answer. I am running AD, but that turned out not to be the reason for this particular issue. –  kervin Jul 19 '09 at 22:14
add comment

On the Network Connections with the public IPs you'll want to remove the DNS Server's IP addresses completely. Just leave the DNS Servers blank for that NIC. Only have DNS Server IPs on the private IP NIC.

share|improve this answer
    
Thanks for the answer. It turned out that I hadn't chosen the interfaces I would like DNS to listen on. –  kervin Jul 19 '09 at 22:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.