Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have bought a domain from 123-reg.co.uk and have successfully pointed it to the IP Address of my Linode VPS so that going to the domain serves up the pages from the Apache server running on the VPS. The instructions I followed to do this are : enter image description here

Now, I am trying to get the domain's mail handled by Google Apps for Business.

I have tried updating the MX records at Linode following this tutorial : http://library.linode.com/email/google-mail

And also followed the instructions to update the MX Records in 123-reg's control panel : enter image description here

I am slightly confused now. Where should I be adding the MX records? In my domain registrar's control panel or in Linode's VPS? Both have options to update the MX records.

share|improve this question

closed as too localized by John Gardeniers, EEAA, Magellan, mdpc, Scott Pack Nov 6 '12 at 18:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
DNS doesn't propagate. If you're still waiting for Google Apps to finishing validation (as stated in a comment below) read the Google Apps documentation and ensure you complete the necessary steps. –  John Gardeniers Sep 15 '12 at 6:50
add comment

2 Answers

As your nameservers are now pointed to linode, you have to setup every new record at linode. By setting your nameservers to linode, their nameservers are now responsible for resolving any dns query.

share|improve this answer
    
how long does it take for MX records to propagate ? It's been more than 12 hours and my in Google Apps it still says MX records setup validation in progress –  Ashutosh Jindal Sep 15 '12 at 6:27
add comment

I found the fix here !

Now the important part:
1. changed my mx records from UPPERCASE TO lowercase
2. clicked on "I completed these steps"
3. clicked on "I will do this later..."
4. clicked again on "I completed these steps"

It was only a matter of putting the MX record hostnames in lowercase.

share|improve this answer
    
strange, usually, the dns system isn't case sensitive ... –  Christopher Perrin Sep 15 '12 at 22:12
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.