Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed git with gitolite on my vserver using this tutorial.

But I've got a problem to clone the gitolite-admin repo to my computer. The user is created with the option --disabled-password

But if I try to clone with

git clone git@<server>:gitolite-admin.git

he asks not only for the passphrase of my rsa_key but also for the password of the gituser.

Anyone an idea? I thought the user is created without password and I don't know what to type in

share|improve this question
up vote 4 down vote accepted

he asks not only for the passphrase of my rsa_key but also for the password of the gituser.

That means the ssh has failed to authenticate the request through the public_key (either because said public key hasn't been found on the client side, or is incorrectly registered on the server side, or the passphrase hasn't been provided, is the key is passphrase protected, by an ssh-agent).
In that case, ssh default to an account password for identification (wether or not the account is created with a password).

Do a ssh -Tvvv git@<server> to better troubleshoot what exactly causes the ssh command to fail.

share|improve this answer
thank you, I found out, that in my /ssh/sshd_config the gituser wasn't allowed to connect – Sven Jung Sep 15 '12 at 15:06
wondering (FOR Sven) - which setting are you referring to - PubkeyAuthentication or something else? – ali haider Jan 23 '13 at 17:23
@alihaider you should put @Sven is you want Sven to be notified of your comment. – VonC Jan 23 '13 at 17:47
@VonC thanks - I apparently need more coffee today (besides a brain transplant). – ali haider Jan 23 '13 at 18:00

I had the same problem, I solved it by adding

AllowUsers git

in /etc/ssh/sshd_config file

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.